Questions tagged [nix-shell]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
12 views

Error when building HSL for GHC 8.10.4.20210212

I'm trying to get the haskell language server installed on my mac and I"m following the docs at https://docs.plutus-community.com/docs/setup/editors/prerequisites.html but they seem to not work. ...
0
votes
0answers
40 views

Why Cabal will not build Cardano api?

Hi I was just following lecture 1 when trying to build the Auction contract. Plutus commit: ea0ca4e9f9821a9dbfc5255fa0f42b6f2b3887c4 I ran Cabal clean, Cabal update, then added brew install libsodium-...
2
votes
1answer
20 views

nix-shell stuck on Building library for hnix

I'm just gonna post a problem that I've been experiencing for a few days (and having a hard time searching for the answer on the internet) and the solution, so that future questions can refer to this ...
2
votes
2answers
134 views

How to compile plutus source code locally?

I'm trying to compile the Plutus source code locally, I tried cabal build in nix-shell, getting this error After searching the rest of the dependency tree exhaustively, these were the goals I've had ...
1
vote
1answer
33 views

How to get latest version of Plutus in project file of plutus-starter-devcontainer

I've been trying to get the latest version of plutus on my project but I get the following error message when I run nix-shell: error: attribute '8a20664f00d8f396920385947903761a9a897fe0' missing, at /...
4
votes
1answer
115 views

403 Forbidden when trying to run nix-shell during setup for Plutus Pioneer Program

I've seen other questions similar to this about a 404 error, but this is different. I have the IOHK Plutus cache set up as per the instructions. Getting the following error: trying https://bintray.com/...
6
votes
2answers
232 views

I'm having issues with nix-shell

I keep getting this error, any thoughts? I have re-downloaded nix 3 times now and it's the same error as before. Not sure if it's the profiles or channels but this is what it gives me: '''trying https:...