I'm using MacOS Monterey with M1 chip, and trying to build plutus-app using Nix

Entering $ nix-shell using the specified tag from week01 is working fine, hence I can enter into the shell. The problem starts when I run $ cabal build inside plutus-pioneer-program/code/week01

I'm encountering this issue where it seems like libsodium isn't installed correctly.

Installation guide I follow: https://github.com/renzwo/cardano-plutus-apps-install-m1

This solution isn't working for me either, or rather, because of different topic (it discussed about plutus-starter, whereas this is for Plutus Pioneer 3): Cabal build all failing with error: Symbol not found: _sodium_free

Additional info:

  • running nix-shell in specified tag commit for week01
  • running nix-shell no problem with IOHK binary cache already specified in nix.conf
  • I've reinstalled nix and tried it again, but it still give me the same result.

I'm stuck here, and don't have any other machine to spin up Ubuntu at the moment.

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy