Questions tagged [haskell-language-server]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer

VSCode HLS not working for plutus project

System Info: Ubuntu :20.04 I am trying to get VSCode HLS extension working for plutus based project but seeing below error in output. Failed to get project GHC version: no cradle [Info - 3:27:24 p.m.]...
5 votes
0 answers

Cannot Get haskell-language-server running - duplicate symbol "sqlite3_fts3_may_be_corrupt"

hoping someone can help with this So, I would like to get the haskell-language-server running, in the context of the plutus-pioneers-program, so that in VS Code I can Ctrl+Click and view type ...
2 votes
1 answer

HLS Compiler Error PPP (WSL2 + VSCode)

I'm trying to get HLS (Haskell Language Server) working in VSCode using WSL2 so I can get type hints. I've already ran through the week01 instructions so I have a working nix installation. However, ...
1 vote
1 answer

Haskell Language Server - linker error: symbol sqlite3_fts3_may_be_corrupt

When I run haskell-language-server in nix-shell in plutus-pioneer-progam i get this error. sqlite3_fts3_may_be_corrupt whilst processing object file /nix/store/jmhwwzn1yfjzlxavz16afkf1r4shmp8z-...
  • 11
1 vote
4 answers

I have a cardano internal error

I ran the Cardano node command and it was fetching new tips for like a minuet then i get this error: cardano-node: internal error: Unable to commit 1048576 bytes of memory (GHC version 8.10.4 for ...
  • 11
1 vote
1 answer

HSL error for Datakinds extension in Week01 in VSCode

I'm trying to get type definitions for Plutus code in VSCode and I'm getting an unusual error. The first extension in the file is {-# LANGUAGE DataKinds #-} (<- this is a clickable link) and the ...