4

I've seen other questions similar to this about a 404 error, but this is different. I have the IOHK Plutus cache set up as per the instructions.

Getting the following error:

trying https://bintray.com/joneshf/generic/download_file?file_path=purty-6.2.0-linux.tar.gz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 403 Forbidden
error: cannot download download_file?file_path=purty-6.2.0-linux.tar.gz from any mirror
builder for '/nix/store/g0drypafpyzckkpwzplp9k9amx4bf7a4-download_file?file_path=purty-6.2.0-linux.tar.gz.drv' failed with exit code 1
building '/nix/store/m63hg37ygw5xkjkd429xds19qkffr6m3-easy-file-lib-easy-file-0.2.2-config.drv'...
cannot build derivation '/nix/store/wdgbj9xf3rz44xz5afw20m1ns0n8llpg-purty-6.2.0.drv': 1 dependencies couldn't be built
error: build of '/nix/store/05snx37ayscns4jfqq62v8ignps9izml-plutus-pab-generate-purs.drv', '/nix/store/08hhl408j6anygi2xf33xjdq4ciy2mxp-loch-th-lib-loch-th-0.2.2.drv', .....

I'm running on windows via WSL (Windows Subsystem for Linux) running Ubuntu

6
  • Please try the methods given cardano.stackexchange.com/questions/413/….
    – raghu
    Jul 10 at 13:53
  • Yes, I've already tried those suggestions. Same result
    – mal
    Jul 10 at 14:06
  • The nix is trying to download from bintry which is outdated. Please update the question with details of your nix installation including version.
    – raghu
    Jul 10 at 14:10
  • Ok thanks! I'll refresh my vm and try again
    – mal
    Jul 10 at 14:11
  • I'll update the question too
    – mal
    Jul 10 at 14:13
3

So it looks like I initially built on the master branch by mistake. Switching to the correct branch and recompiling didn't help the situation. I reset my WSL instance of Ubuntu and started again, more carefully this time. Everything worked as it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.