0

I am getting the following error after running cabal build using nix-shell:

cabal: Could not resolve dependencies:
[__0] next goal: Win32-network (user goal)
[__0] rejecting: Win32-network-0.1.1.0/installed-Cm3H3JOsc0sL7v05D4U9jQ
(constraint from user target requires ==0.1.0.0)
[__0] trying: Win32-network-0.1.0.0
[__1] trying: base-4.14.3.0/installed-4.14.3.0 (dependency of Win32-network)
[__2] trying: lobemo-scribe-systemd-0.1.0.0 (user goal)
[__3] next goal: libsystemd-journal (dependency of lobemo-scribe-systemd)
[__3] rejecting: libsystemd-journal-1.4.5 (conflict: pkg-config package
libsystemd>=209, not found in the pkg-config database)
[__3] rejecting: libsystemd-journal-1.4.4 (conflict:
base==4.14.3.0/installed-4.14.3.0, libsystemd-journal => base>=4.6 && <4.13)
[__3] skipping: libsystemd-journal-1.4.3, libsystemd-journal-1.4.2,
libsystemd-journal-1.4.1, libsystemd-journal-1.4.0, libsystemd-journal-1.3.4,
libsystemd-journal-1.3.3, libsystemd-journal-1.3.1, libsystemd-journal-1.3.0,
libsystemd-journal-1.2.0, libsystemd-journal-1.1.0, libsystemd-journal-1.0.0
(has the same characteristics that caused the previous version to fail:
excludes 'base' version 4.14.3.0)
[__3] fail (backjumping, conflict set: base, libsystemd-journal,
lobemo-scribe-systemd)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, libsystemd-journal,
lobemo-scribe-systemd, Win32-network
Try running with --minimize-conflict-set to improve the error message.

I am using cabal 3.6.2.0 and ghc 8.10.7

9
  • The conflict suggests your ghc may be too new, try with 8.10.7
    – james
    Feb 2, 2023 at 18:09
  • Hey James, thanks for your reply but that was actually a typo. I have just corrected the GHC version in the post. Feb 2, 2023 at 22:15
  • In that case, try entering shell with nix develop as per the contributing doc: github.com/input-output-hk/plutus/blob/master/CONTRIBUTING.adoc
    – james
    Feb 3, 2023 at 9:41
  • I am getting this error when I want to run nix develop: error: flake 'git+file:///home/matifalcone/Blockchain/Cardano/Plutus/plutus-apps' does not provide attribute 'devShells.x86_64-linux.default', 'devShell.x86_64-linux', 'packages.x86_64-linux.default' or 'defaultPackage.x86_64-linux' Feb 4, 2023 at 2:53
  • Right, that's for plutus repo. For plutus-apps follow instructions in github.com/input-output-hk/plutus-apps/blob/main/…
    – james
    Feb 6, 2023 at 9:17

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.