Questions tagged [vscode]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
15 views

How do I set Up a Cabal file?

Whats a basic template I should use for cabal files that is easily customisable?
user avatar
0 votes
0 answers
31 views

How to fix `cabal build` in Plutus Starter Dev Container

I have seen other people with this problem on Github. Broken cabal build Following these instructions, I am able to get to the line that says: cabal build from the terminal should work (unless you ...
user avatar
0 votes
0 answers
66 views

VS Code Haskell Language Server configuration: pass flag to cabal?

I'm working with the plutus-starter repo (https://github.com/input-output-hk/plutus-starter) and this is working with VS Code on my Macbook Pro and running in a Docker devcontainer. HSL even shows ...
user avatar
  • 195
1 vote
1 answer
38 views

VS Code Remote VM IntelliSense Issues

I was having trouble getting Plutus running properly on Windows & WSL2, so I spun up an Ubuntu Server VM on my Proxmox server and set everything up there. I use VS Code via SSH to connect from ...
user avatar
  • 11
2 votes
1 answer
111 views

HLS Compiler Error PPP (WSL2 + VSCode)

I'm trying to get HLS (Haskell Language Server) working in VSCode using WSL2 so I can get type hints. I've already ran through the week01 instructions so I have a working nix installation. However, ...
user avatar
0 votes
0 answers
22 views

"No unfolding" error in Visual Studio Code

I copied the Plutus starter template, Plutus Platform starter project, and created a file, BasicPlutusTx.hs (and added it under exposed-modules in the .cabal file). Then I started copying over all the ...
user avatar
  • 123
0 votes
1 answer
50 views

VSCode + Docker setup problems on Mac (Intel)

I am following the steps as described in the repository, using VSCode and Docker. https://github.com/input-output-hk/plutus-starter All the dependencies looks good, but it failed on building the ...
user avatar
0 votes
1 answer
57 views

cabal build Out of Memory Mac VS Code Docker

This is a follow up to my previous cabal build problem. I ran cabal update. Then cabal build was killed. I tried increasing Docker memory from 2GB to 3GB. My old Mac has 8GB, Activity Monitor peaked ...
user avatar
2 votes
1 answer
55 views

cabal: Could not resolve dependencies:plutus-core:happy:exe.happy

In the VS Code Docker Env setup on a Mac. I opened the starter project in the container. Ran cabal build in VS Terminal with devcontainer prompt. Warning: Requested index-state 2021-08-14T00:00:00Z is ...
user avatar
1 vote
1 answer
44 views

HSL error for Datakinds extension in Week01 in VSCode

I'm trying to get type definitions for Plutus code in VSCode and I'm getting an unusual error. The first extension in the file is {-# LANGUAGE DataKinds #-} (<- this is a clickable link) and the ...
user avatar
5 votes
0 answers
175 views

Plutus-Start for Windows - Cannot get the docker repository to run (A mount config is invalid.)

I am following : https://github.com/input-output-hk/plutus-starter I have downloaded VSCode and Docker. I downloaded the Remote Development extension in VSCode. I then ran "mkdir -p ~/.cabal/...
user avatar
5 votes
0 answers
77 views

Launch.json for VSCode/Haskell? Learning Haskell Plutus

I have VSCode all set up with the necessary Haskell plugins (except I have GHCI 9.x installed via Chocolatey and the plugins want 8.x, ouch! Unfortunately Chocolatey won't accept an 8.x "--...
user avatar
4 votes
2 answers
284 views

Problem with creation of wallet using Javascript

Im using linux-Ubuntu in the WSL of the Windows 10. I have installed Cardano-node and Cardano-cli. Node v14 (latest stable version) ghc 8.10.6 Im trying to create a wallet but on this command: node ...
user avatar
6 votes
2 answers
190 views

haskell-language-server used in VSCode Haskell extension produces spurious INLINABLE compilation error message

When compiling supplied code for Plutus Pioneer Program, the haskell extension for VSCode IDE reports a compilation error. This prevents a lot of useful IDE functions from working, because the IDE ...
user avatar
  • 161
6 votes
0 answers
87 views

Can you run the Plutus playground and serve the Haddock documentation from the VSCode devcontainer?

I am still looking to settle on a dev environment for Plutus contracts. I am thinking about using VSCode with the devcontainer, but would like to know how well it all integrates. Is it easy to have ...
user avatar
  • 460
8 votes
1 answer
86 views

How to get intellisense/auto suggestion working for Plutus in VSCode?

I've been seeing Lars get auto suggestions from his terminal when he's typing. I want the same in VSCode, how to get it? PS: I don't get auto suggestions in cabal repl too.
user avatar
7 votes
3 answers
688 views

Problem starting a plutus devcontainer in windows

After I upgraded my container to the commit from plutus pioneer programm lecture 3 the VsCode server won't spawn anymore in the dev container. VSCode tells could not fetch remote environment Failed ...
user avatar
  • 639