1

So I've been going through the Plutus Pioneers 3rd cohort lectures and last night accidentally left my computer unplugged. When I booted up Ubuntu Linux on the computer this morning I noticed I have 3 copies of plutus-apps folders on my computer and I only use one for going in nix-shell and running plutus playground so I deleted the other 2.

I went to set up Plutus-Playground-Server for a new lecture and went through the steps here to get everything set back up again (which have worked fine before since I've set it all up already).

https://plutus-community.readthedocs.io/en/latest/#Plutus/Build/Ubuntu/

In terminal window 1

cd plutus-apps
nix-shell
cd plutus-playground-server
plutus-playground-server

However, I am getting these errors (tried sudo plutus-playground-server as well, didn't work).

enter image description here

I thought maybe there's something that needs updating so I updated all my apps. I noticed my Nix is running on 2.8.1 and now there is 2.10

https://nixos.org/download.html

Tried several ways of updating nix including the methods given in the link, I keep getting these similar permission denied messages. Sudo doesn't work in this instance.

[nix-shell:~/plutus-apps/plutus-playground-client]$ GC_DONT_GC=1 plutus-playground-server
plutus-playground-server: for development use only
error: opening lock file '/nix/store/69h1ik7v55mi947xfn28bwxkvn2fn4z9-plutus-apps-root-plutus-ledger-constraints-lib-plutus-ledger-constraints-root.lock': Permission denied
(use '--show-trace' to show detailed location information)
error: opening lock file '/nix/store/69h1ik7v55mi947xfn28bwxkvn2fn4z9-plutus-apps-root-plutus-ledger-constraints-lib-plutus-ledger-constraints-root.lock': Permission denied
(use '--show-trace' to show detailed location information)
/nix/store/fm77y43lzpgnay4pyc48jwpln0lnmrk3-plutus-playground-server/bin/plutus-playground-server: line 10: /bin/plutus-playground-server: No such file or directory

Just to try everything I tried changing git versions of plutus-apps like you need to do as you go through plutus cohort #3. I did git checkout for different weeks of the plutus pioneer program and i'm getting:

fatal: reference is not a tree

enter image description here

However, the git checkout in plutus-community docs works just fine (but plutus playground server still doesn't work).

https://plutus-community.readthedocs.io/en/latest/#Guides/BuildCabalBuild/

I have restarted my computer as per this link, still getting the same errors.

/bin/plutus-playground-server: No such file or directory

Is this having to do with the new cardano node 1.35.3 and the Vasil upgrade or just a bonehead move on my part? Any help is appreciated, thanks!

3
  • Had the same issue yesterday on Mac. GC_DONT_GC=1 did the trick for me. Maybe restarting nix-daemon will work: sudo pkill nix-daemon & sudo nix-daemon &
    – et97
    Aug 16, 2022 at 9:22
  • I forgot to mention I'm on Ubuntu. I don't think that'll make much of a difference with Mac. / When I did sudo pkill nix-daemon & sudo nix-daemon & / went into nix-shell in plutus-apps / changed directory to plutus-playground-client / and ran plutus-playground-server I have only one error error: opening lock file '/nix/store/69h1ik7v55mi947xfn28bwxkvn2fn4z9-plutus-apps-root-plutus-ledger-constraints-lib-plutus-ledger-constraints-root.lock': Permission denied (use '--show-trace' to show detailed location information) Aug 16, 2022 at 21:37
  • whereas before I would get the error twice. GC_DONT_GC=1 plutus-playground-server gives same error 2 times just like before, it's not working for me. ----- Now the next thing I need to figure out is how to enter new lines in comments on stack exchange comments so my replies can look cleaner... Aug 16, 2022 at 21:40

1 Answer 1

1

Went back and tried getting it to work today, first went to this link https://www.punkbit.com/hacking/plutus-developer-environment-setup-on-macos-monterey/#6-run-the-plutus-playground-service-and-frontend

and added in my nix.conf file

build-users-group = nixbld

the playground server still wasn't working so I found someone having a similar github issue with Nix here

https://github.com/NixOS/nix/issues/4356

sudo chown -R "Your User Account Name":staff /nix

afterwards plutus-playground-server worked, no extra GC_DONT_GC=1 needed in my case.

This makes sense because I was getting logged permission errors from nix and this command gives me ownership of nix folder and subdirectories.

2nd terminal with

cd plutus-apps
nix-shell
cd plutus-playground-client
npm run start

is working fine, the plutus playground server is running for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.