I successfully installed NixOS on a Mac M1. However, running either nix-shell or GC_DONT_GC=1 nix-shell from within /marlowe-cardano (in the marlowe-pioneers branch) produces:

error: cannot bootstrap GHC on this platform ('aarch64-darwin' with libc 'defaultLibc')

Any ideas on how to get past this?

1 Answer 1


It seems that you did a multi-user w/ daemon installation. I am aware that a functioning guide is here

so get nix using the darwing unencrypted label

sh <(curl -L https://nixos.org/nix/install) --darwin-use-unencrypted-nix-store-volume

edit your sudo nano /etc/nix/nix.conf file, by adding IOHK's binaries:

build-users-group = nixbld

substituters        = https://hydra.iohk.io https://iohk.cachix.org https://cache.nixos.org/
trusted-public-keys = hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ= iohk.cachix.org-1:DpRUyj7h7V830dp/i6Nti+NEO2/nhblbov/8MW7Rqoo= cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=

system = x86_64-darwin
extra-platforms = x86_64-darwin aarch64-darwin

sandbox = false
extra-sandbox-paths = /System/Library/Frameworks /System/Library/PrivateFrameworks /usr/lib /private/tmp /private/var/tmp /usr/bin/env
experimental-features = nix-command
extra-experimental-features = flakes

reboot and you should be good to go.

note I am no Nix expert nut if the problem persists then you might need to completely uninstall Nix first, which is not so trivial.

  • 2
    This was spot on, thanks! I did have to uninstall nix first. Also needed to be in the /marlowe-cardano directory during installation in order to be able to run nix-shell.
    – DaveLind
    May 30, 2022 at 18:58
  • Glad it worked! If you upvote and mark my answer as solved it will help other people find it ;)
    – Igodlab
    May 30, 2022 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.