1

I just ran sh <(curl -L https://nixos.org/nix/install) --daemon to install nix via its installation instructions. I proceeded through the installation menu where it backs up your bashrc and other config files. y on sudo permissions, it installs and doesn't complain.

systemctl status systemctl status nix-daemon.service daemon running with no issues. However when I execute nix-shell I get

nix-shell: /nix/store/jsp3h3wpzc842j0rz61m5ly71ak6qgdn-glibc-2.32-54/lib/libc.so.6: version GLIBC_2.33' not found (required by /usr/local/lib/libsodium.so.23)

When I execute nix-env --version same error.

I've uninstalled / reinstalled nix several times now and getting the same error. Checked Fedora 35 glibc version ldd --version and get back 2.34

Any advice on getting nix-shell to execute properly in Fedora 35?

2
  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Commented Jan 14, 2022 at 4:39
  • Where id you run nix-shell, in which folder?
    – angerman
    Commented Jan 14, 2022 at 4:43

3 Answers 3

3

Fixed. I had the Cardano node previously installed which involves compiling and installing libsodium. What I did was go into the libsodium folder and sudo make libsodium uninstall Then re-ran nix installation and now I get a nix-shell.

2
  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Commented Jan 16, 2022 at 4:25
  • For me the make command failed and I had to go to /usr/local/lib, created a backup directory and moved all libsodium.* files to it. This removed that existing lib and nix installed fine.
    – Skelli
    Commented Feb 8, 2022 at 13:56
0

I went ahead and got ahold of a fedora 35 install. I was not able to install the --daemon version, due to fedoras SELinux enforcement. I did however manage to install nix in single user mode.

and nix-shell works.

$ nix-shell -p hello
these 42 paths will be fetched (61.29 MiB download, 281.92 MiB unpacked):
...
[nix-shell:~]$ hello
Hello, world!

[nix-shell:~]$
1
  • Sadly I'm getting the same error with single user mode installation. sh <(curl -L https://nixos.org/nix/install) --no-daemon copying Nix to /nix/store........................................... /nix/store/azld8vfyqb4fx6bxdz28n3nw23nghf88-nix-2.5.1/bin/nix-store: /nix/store/jsp3h3wpzc842j0rz61m5ly71ak6qgdn-glibc-2.32-54/lib/libc.so.6: version `GLIBC_2.33' not found (required by /usr/local/lib/libsodium.so.23) /tmp/nix-binary-tarball-unpack.PWdwdaEWRp/unpack/nix-2.5.1-x86_64-linux/install: unable to register valid paths
    – drock00
    Commented Jan 14, 2022 at 23:49
0

I had the same issue. I noticed it happens when you had/have previously setup a Cardano node since that required setting up libsodium. The issue is with the LD_LIBRARY_PATH envronment variable added in the process.

To solve it I commented out that variable export in the ~/.bashrc file. You may need to restart the terminal for the change to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.