Questions tagged [nixos]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
16 views

How do I set Up a Cabal file?

Whats a basic template I should use for cabal files that is easily customisable?
user avatar
0 votes
1 answer
20 views

How to install the Marlowe Pioneers Daedalus bin in NixOS?

To enhance my education during the Marlowe Pioneers program (with simultaneous Emurgo Haskell Dev Pro course), I've been running NixOS as my daily driver for full immersion over the past two weeks or ...
user avatar
0 votes
1 answer
54 views

How Do you generate the Cabal and Nix files for a new project?

I built the plutus-apps repo from iohk, and then made a different folder to orgenise my projects. I want to know how to have the nix files needed to make the environment generated in the new project ...
user avatar
0 votes
0 answers
14 views

Child compilation failed [duplicate]

Hello Cardano community. This question has been asked in the community and I would like to resurface it as I am having the same problem. Ref: plutus-playground-client npm start error (MacOs Intel i7) ...
user avatar
  • 11
0 votes
2 answers
81 views

How to set plutus-apps NixOS options on Mac

This is the first time I've used nix. On plutus-apps readme, I changed nix.conf but I don't know how to do this step. 2.On NixOS, set the following NixOS options: nix = { binaryCaches = [ &...
user avatar
6 votes
2 answers
426 views

I'm having issues with nix-shell

I keep getting this error, any thoughts? I have re-downloaded nix 3 times now and it's the same error as before. Not sure if it's the profiles or channels but this is what it gives me: '''trying https:...
user avatar
  • 677
7 votes
1 answer
367 views

Problem when starting a nix-shell in the plututs repo [duplicate]

I was doing the plutus pioneer program and ran into an error when starting a nix-shell at the top-level directory of the plutus-repository. I ran into the same error on Ubuntu 20.04.2 LTS (GNU/Linux ...
user avatar
  • 150