0

I'm unable to run nix-shell on my new M2 Macbook.

I read through the posts from last year on setting up M1 Macbooks with previous plutus-apps tags, but the same steps do not seem to work.

Environment: I'm using a new M2 Macbook and plutus-apps tag v1.1.0

I followed the plutus-community install steps for M1 from https://github.com/input-output-hk/plutus-community/blob/main/docs/Environment/Build/Mac_M1.md

  • only change to this was in substituters and trusted keys (see notes below for more detail)

I installed Rosetta 2 with

sudo softwareupdate --install-rosetta --agree-to-license

and installed nix package manager with

sh <(curl -L https://nixos.org/nix/install)

this is my nix.conf

build-users-group = nixbld

experimental-features = nix-command flakes

substituters = https://cache.iog.io https://cache.nixos.org https://digitallyinduced.cachix.org https://all-hies.cachix.org https://cache.zw3rk.com

trusted-public-keys = hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ= cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY= digitallyinduced.cachix.org-1:y+wQvrnxQ+PdEsCt91rmvv39qRCYzEgGQaldK26hCKE= all-hies.cachix.org-1:JjrzAOEUsD9ZMt8fdFbzo3jNAyEWlPAwdVuHw4RD43k= loony-tools:pr9m4BkM/5/eSTZlkQyRt57Jz7OMBxNSUiMC4FkcNfk=

system = x86_64-darwin
extra-platforms = x86_64-darwin aarch64-darwin

sandbox = false
extra-sandbox-paths = /System/Library/Frameworks /System/Library/PrivateFrameworks /usr/lib /private/tmp /private/var/tmp /usr/bin/env

keep-outputs = true
keep-derivations = true

& with that conf when I try to spin up plutus-apps I was finally able to get nix build -f default.nix docs.site to run, and I got past the standard M1 error I was seeing people have. (https://github.com/input-output-hk/plutus-apps/issues/632)

Once I got past that error (with the updated nix conf above), and nix build completes successfully, when I run nix-shell I get this error

segmentation fault  nix-shell

not very insightful error at all, and I am out of ideas on what might be causing it

any ideas on what might be going on or what else I can try?

Some other notes:

  • The old posts/solutions include hydra as a substituter, but this repo was deprecated last year by IOG in a node upgrade, so I've removed it
  • I have a couple of other substituters and trusted keys in there from a separate repo I was trying out, but I doubt those are related to this issue.

1 Answer 1

2

After days of spelunking the internet, I found a comment in IOG ask-nix-os suggesting to use

GC_DONT_GC=1 nix-shell

and that solved the problem.

As of today, if you follow all the steps in my issue post, plus run your nix shell with the prefix above you should be able to successfully get nix working with an M1/M2 Macbook

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.