Questions tagged [plutus-playground]

The tag has no usage guidance.

8 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7
votes
1answer
91 views

Plutus Pioneer Cohort 2 Lecture 3

I was going through the lecture on Youtube and this is the one with Vesting example where: wallet 1 gifts 20 ADA to wallet 2 in 2 different slots wallet 1 gifts 10 ADA to wallet 3 in a slot later on, ...
5
votes
0answers
37 views

Can you run the Plutus playground and serve the Haddock documentation from the VSCode devcontainer?

I am still looking to settle on a dev environment for Plutus contracts. I am thinking about using VSCode with the devcontainer, but would like to know how well it all integrates. Is it easy to have ...
3
votes
0answers
27 views

When can we expect live deployment of the Plutus Playground

I am working with a low end device, and the live deployment of the playground is what I'm counting on. When can I expect it and is there any community deployed server that is active now?
3
votes
1answer
73 views

plutus-playground-server: user error (Error evaluating simulation: JsonDecodingError

I'm following the first lecture in the plutus pioneer program but I cannot set up the local environment. The error happens when running npm start on a nix-shell after initializing the playground ...
3
votes
1answer
68 views

Setting up Plutus environment for Apple Silicon computer

I'm trying to setup dependencies to write and test plutus contracts, but I'm worried that the dependencies may not be compatible with the M1 chip. I have been following these instructions https://www....
3
votes
0answers
94 views

Using Plutus PAB for development instead of Playground

trying to migrate away from the playground and seems like PAB is the way to go. The plutus starter repository orignally seems to be the best place to start but it seems to be outdated (i.e. still ...
1
vote
0answers
18 views

Error Starting plutus-playground-client

I'm having error running the plutus-playground-client. Not sure where to look, here is the complete error log. Any suggestions on how to fix? 0 info it worked if it ends with ok 1 verbose cli [ 1 ...
0
votes
0answers
14 views

Plutus Pioneer Program Week02: grab endpoint not working and trace log being cut off

Here you can see the 'grab' endpoint being correctly set. And here you can see the Tx2 slot for the grab endpoint is missing. Also, some lines of the trace are being cut off, I'm not sure if this is ...