Questions tagged [plutus-playground]

Plutus Playground provides an environment for writing and testing smart contracts before they are released on the Cardano blockchain.

Filter by
Sorted by
Tagged with
0 votes
1 answer

plutus-playground-client crashes on Intel Mac (Big Sur)

After setting up environment for cohort 3 of the pioneers program, running the plutus-playground-client crashes on my Intel Mac (Big Sur). I've been able to successfully set up Nix and all the code ...
Steve Mason's user avatar
7 votes
2 answers

I'm having issues with nix-shell

I keep getting this error, any thoughts? I have re-downloaded nix 3 times now and it's the same error as before. Not sure if it's the profiles or channels but this is what it gives me: '''trying https:...
KIJIRI's user avatar
  • 687
4 votes
2 answers

What documentation works with handling utxos at the Plutus Script?

I am trying to make a Plutus smart contract which takes tokens locked to the contract and then on endpoint call (purchase) sends 1 to the caller and then the rest back to the contract. I cant find a ...
Floof99's user avatar
  • 472
2 votes
1 answer

Lessons Learned setting up plutus-playground - feedback welcome [closed]

I have finally got the plutus-playground running on 2 separate machines. Each machine is a Mac running Catalina 10.15.7. After extensive trial and error (some self inflicted) I have identified several ...
XiTouch's user avatar
  • 349
2 votes
2 answers

/bin/plutus-playground-server: No such file or directory

Can't get plutus-playground-server to start. plutus-playground-server: for development use only /nix/store/601kdlvidgan842yfklrmvpbz6a5xkf7-plutus-playground-server/bin/plutus-playground-server: line ...
ryanaverell's user avatar
1 vote
3 answers

Error running plutus-playground-client in Linux

I have successfully installed nix, cabal and have setup the IOHK binary cache. I cloned the plutus-app repository and successfully built the Haskell packages and other artifacts with nix. Then running ...
d_fajardo's user avatar
  • 198
1 vote
1 answer

Error Starting plutus-playground-client

I'm having error running the plutus-playground-client. Not sure where to look, here is the complete error log. Any suggestions on how to fix? 0 info it worked if it ends with ok 1 verbose cli [ 1 ...
Local Host's user avatar
0 votes
1 answer

Unable to start /plutus-apps client application

Error is occurring for MacOS 12.1 Monterey. Please, let me know, if I should include additional details. I am going through the step noted in this document in order to setup local Plutus app: https://...
Radoslav Naidenov's user avatar
0 votes
1 answer

plutus-playground-server sense of time is incorrect

I think my plutus-playground-server has an incorrect notion of time. I'm working on the homework for lecture 3 and keep running into issues with the simulator. Here's a screenshot of what I'm ...
Paymahn Moghadasian's user avatar