3

trying to migrate away from the playground and seems like PAB is the way to go. The plutus starter repository orignally seems to be the best place to start but it seems to be outdated (i.e. still using ValidatorCtx instead of ScriptCtx). So Im looking the plutus-pab in the main plutus repo. I ran the all-servers script and tried activating the in built plutus game contract using the HTTP api of the webserver but encounted an error in the json object stating that the caID shld be a binary instead of a string. How do I overcome this? Thanks.enter image description here

3
  • 1
    Hi Shannon, could you please provide some more information? Links to the repositories you're using, the exact steps you did and the full error message would be helpful.
    – eddex
    Jun 7 at 17:25
  • caID is part of ContractActivationArgs - are you sure the error message is telling you that this should be a binary (and not maybe a ByteString - which is different than String)?
    – Matthias Sieber
    Jun 7 at 20:20
  • Added a screenshot of what I see with the latest code as of now. I remembered the error being a binary but now it shows an object; I'll just take it that I remembered wrongly. Where do I find the caID for the built-in contracts? Thanks. Jun 9 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.