New answers tagged

0

the coresponding version for you can find there $cd ~/code/haskell/plutus-pioneer-program/code/week01/ $less cabal.project and there is a tag with right version


0

I had the same issue. I changed my docker settings to use 8Gb memory and 2Gb swap and that worked. It was possible because my Mac has 16Gb memory, and that is not your case. As your Mac has only 8Gb, I would suggest you bump up your swap a little bit more, maybe 4Gb. I played with my settings a little bit and 4GB of swap was the limit, maybe you would need ...


0

Build was actually successful it seems - was just taken a back by the compiler warning. I re-ran cabal build and then it just game me an output Up to date


3

In our context of smart contracts, cabal build builds the executables needed for doing cabal run, which we use to build the Plutus validator. cabal repl, in the other hand loads all the modules that are in your project into GHCi, which is ready to be used in interpreted code. In this context you can test your validator or your off-chain code in an ...


0

just a thought, did you checkout the right tag in plutus-apps repo beforehand?


1

It was newbie mistake. There are these lines at the top {-# LANGUAGE DataKinds #-} {-# LANGUAGE DeriveAnyClass #-} {-# LANGUAGE DeriveGeneric #-} {-# LANGUAGE DerivingStrategies #-} {-# LANGUAGE FlexibleContexts #-} {-# LANGUAGE GeneralizedNewtypeDeriving #-} {-# LANGUAGE LambdaCase #...


0

Perhaps you need to add ‘bytestring’ to the build-depends in your .cabal file. Do you have a cabal file somewhere? If so, you need to add the bytestring package.


0

Somewhere you have a typo. "ByString" should be "ByteString".


1

Why are you using sudo? Try without. And update of course.


1

try "cabal update" before "cabal build".


2

You will not be able to build this in less than 8G of RAM. Adding swap to make the total memory at least 8G may help.


1

The line Falling back to older state () means you probably need to run cabal update first (which downloads a copy of the current hackage index state).


1

Recommended way to build cardano-wallet is with stack. Check out this manual: https://developers.cardano.org/docs/get-started/installing-cardano-wallet I tried to build wallet recently and it was successful. Let me know if you will still have issues building it with stack. Cheers!


Top 50 recent answers are included