Noob here. I am basically just trying to learn plutus on my own I am on week01. When I ran the following command:

[nix-shell:~/plutus-apps/plutus-playground-client]$ npm run start (or even just npm start)

I get this error: enter image description here

I tried "npm audit fix --force" and it did not help. Is there any suggestion on how I can overcome this issue? Thank you!

2 Answers 2


Looks like the --inline option was depecated from webpack as per: https://stackoverflow.com/questions/70528429/webpack-cli-error-webpack-cli-error-unknown-option-inline

What build guide are you following? Do they suggest a certain version of webpack to use? (--inline should still be a valid option within the version that they suggest).

If they don't suggest a webpack version to use then you can go through the various versions on one of the NPM websites to find and install the right one.

Or you might be able to find and remove --inline from the build script, then rerun it.

Or work off of a different/more recent build guide maybe?

  • Hey @MC_Brisbane, I tried all your suggestions: 1) I used the latest iteration of plutus-pioneer-program, 2) used older versions of webpack, 3) deleted --inline from package.jason. None of them solved the issue. Deleting --inline actually threw out a different error. I just really wonder how it's working for others but not for me? I followed all the build instructions to the tee.
    – J.O.C
    Commented May 27, 2022 at 1:15
  • Hi John, can you provide a link to the guide that you are following. Also which was the latest version of webpack that you tried that has --inline included? Commented May 28, 2022 at 0:36
  • Hi MC_Brisbane, thank you for trying to help me with this issue. I basically watch Lars' plutus tutorial videos as well as tutorials from other youtubers. I did not follow the plutus docs because it is outdated and there was no mention about the issue that I am currently having. The third video below really helped me overcome previous issues I've encountered. 1) Lars - youtube.com/… 2) youtube.com/watch?v=mnfItts6VbU 3) youtube.com/watch?v=CXHmbOkoVG8&list=WL&index=1
    – J.O.C
    Commented May 28, 2022 at 17:51
  • Also, the "--inline" that I deleted is not within webpack (I am using 5.72.1) but from the package.json file within the plutus-playground-client folder of plutus-apps. I am not sure if this is what I should delete(?) Thank you again for helping!
    – J.O.C
    Commented May 28, 2022 at 17:52
  • At lot has changed since those 2021 videos were put together, but I'm sure they still have useful info. Looking at the 'PPP 030103' Jan 2022 videos (youtube.com/watch?v=zPaDp4R9X7o), Lars mentions that you need to set up NIX and start by cloning github.com/input-output-hk/plutus-pioneer-program and github.com/input-output-hk/plutus-apps (NOTE: this is not the main plutus codebase) Can you confirm that you followed each of these installation instructions? If not I'd lean towards starting over and following the IOHK github instructions and guidance from Lars' videos. Commented May 30, 2022 at 1:55

Hay man the best way is to spin up a VM like VirtualBox and make sure your dependencies match. Your problem here is that you are using a version of Webpack not compatible with your version of Plutus.

Step 1)

set up Ubuntu VM (recommend Ubuntu 20.4 LTS its the one I'm using so it works). optional setup vscode its pretty good.

Step 2)

Clone Plutus-apps repo

Step 3)

Clone plutus pioners program

Step 4)

install ghc and nixos

step 5)

open up the cabal build file from the week of the PPP your on. Press ctrl + F and look up apps. there should be a plutus-apps now highlighted in the file copy the commit reference right below it.

step 6)

cd into your plutus-apps dir and git checkout <refrance you just copied>

Step 7)


Step 8)

cd to the correct week of Plutus pioneers program

cabal build

code .

you should now be in the environment inside vscode in the correct location ready to code.

to set up the client and server for the playground and the documentation look up the Plutus Env_ Setup Starter Pack.pdf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.