1

I am following https://docs.plutus-community.com/docs/setup/MacOS.html

I know the plutus-apps repo is newer than those docs and have downloaded it but it seems I can't build plutus-pab.

When I run

$ nix-build -A plutus-pab

I get:

error: attribute 'plutus-pab' in selection path 'plutus-pab' not found

I thought I had built everything but when I tried to run $ npm run start in plutus-playground-client I got this:

sh: line 1: plutus-playground-generate-purs: command not found

3
  • I may need to build github.com/input-output-hk/plutus-apps/tree/main/… but when i try $ nix-build ../default.nix -A plutus-apps.haskell.packages.plutus-pab I get Segmentation fault: 11
    – perezda
    Jan 12, 2022 at 16:31
  • Was able to run $nix-build default.nix -A plutus-apps.haskell.packages.plutus-pab from within nix-shell. Seems like it worked, but main problem still not resolved.
    – perezda
    Jan 12, 2022 at 16:46
  • After a reboot, this issue seems to have resolved itself. Unfortunately I'm not sure what I did. Playground client now runs, though I cannot compile the hello world sample. On to tackling next error...
    – perezda
    Jan 12, 2022 at 21:20

1 Answer 1

0

To build needed:

$ nix-build ../default.nix -A plutus-apps.haskell.packages.plutus-pab

in top level of plutus-apps folder.

in plutus-apps/plutus-pab-executables

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.