I am trying to send a market.plutus file to test a NFT marketplace to mainnet. I am building the transaction here like this:

cardano-cli transaction build 
--alonzo-era --mainnet 
--tx-in $UTxO-VARIABLE 
--tx-out $CONTRACT-ADDR-VARIABLE+5400011 
--tx-out-datum-hash 67882f9c671cb45fc6990a2d14a20b30bfce29ad99a401c283a100662e6600fb 
--change-address $MY-ADDR-VARIABLE 
--out-file tx.build

Notice how the --metadata-json-file field is empty. It doesn't let me build it empty of course but I have no idea what goes here or what it should be.

1 Answer 1


'--metadata-json-file' wants a path to a JSON file eg --metadata-json-file metadata.json

This link shows an example of JSON metadata content, adapt and use as needed - https://developers.cardano.org/docs/transaction-metadata/how-to-create-a-metadata-transaction-cli/

You can try leaving out this option, or provide the path to a file (that is either empty or that has minimum JSON data).

It's cheaper to experiment on the testnet, but I'm sure that you're aware of that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.