1

I was having trouble getting Plutus running properly on Windows & WSL2, so I spun up an Ubuntu Server VM on my Proxmox server and set everything up there. I use VS Code via SSH to connect from Windows. The Plutus application/code and playground run without issue, however, there is no IntelliSense for the Haskell code.

I already have the Haskell extension installed in VS Code for the remote VM (as suggested here: How to get intellisense/auto suggestion working for Plutus in VSCode?). The extension does not have any errors. It does act like it is processing the files, but the types, etc. never appear on hover.

I already have Nix, docker & GHC installed on the VM.

I have tried running it in and out of the devcontainer, but no luck with IntelliSense.

Here is the source code: https://github.com/input-output-hk/plutus-pioneer-program/blob/main/code/week02

The one thing that did work with IntelliSense was running the following project via devcontainer: https://github.com/input-output-hk/plutus-starter. However, I currently do not understand why this would vary project to project. I even tried replacing the docker image in the pioneer program devcontainer.json with the one from the starter project, but that didn't work either.

The Plutus Pioneer Program is my first foray into the Haskell ecosystem, so I'm sure it is something fundamental that I have misunderstood. Any clarity on this would be much appreciated.

1 Answer 1

1

Unfortunately this doesn't work in the plutus pioneer program weeks so far (currently week03). Your IDE uses the haskell language server to get type references but if you run the command haskell-language-server in a nix-shell in the current week's repository you will get an error. This is documented in this question: HLS Compiler Error PPP Week01 (WSL2 + VSCode)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.