0

I am running cardano-node 1.35.3 on Ubuntu 22.04 Docker container. I am attempting to run the node on the preview testnet. Below is the following error I get when running cardano-node.

Here is the Error that I am seeing

[22cbd0dd:cardano.node.PeerSelection:Error:52] [2022-09-29 04:11:19.93 UTC] TracePublicRootsFailure Network.Socket.getAddrInfo (called with preferred socket type/protocol: AddrInfo {addrFlags = [AI_ADDRCONFIG,AI_NUMERICHOST,AI_PASSIVE], addrFamily = AF_UNSPEC, addrSocketType = Datagram, addrProtocol = 0, addrAddress = 0.0.0.0:0, addrCanonName = Nothing}, host name: Just "192.168.65.5", service name: Just "domain"): does not exist (Unrecognized service) (-5) 32s
[22cbd0dd:cardano.node.PeerSelection:Info:52] [2022-09-29 04:11:51.89 UTC] TraceGovernorWakeup
[22cbd0dd:cardano.node.PeerSelection:Info:52] [2022-09-29 04:11:51.89 UTC] TracePublicRootsRequest 100 0
[22cbd0dd:cardano.node.LedgerPeers:Info:50] [2022-09-29 04:11:51.89 UTC] [String "FetchingNewLedgerState",Number 0.0]
[22cbd0dd:cardano.node.LedgerPeers:Info:50] [2022-09-29 04:11:51.89 UTC] [String "FallingBackToBootstrapPeers"]
[22cbd0dd:cardano.node.LedgerPeers:Info:50] [2022-09-29 04:11:51.89 UTC] [String "UseLedgerAfter",Number 322000.0]
[22cbd0dd:cardano.node.PublicRootPeers:Info:66] [2022-09-29 04:11:51.89 UTC] TracePublicRootRelayAccessPoint [RelayAccessDomain "preview-node.world.dev.cardano.org" 30002]

Here is my cardano-node run command cardano-node run --topology topology.json --database-path db --socket-path db/node.socket --host-addr 127.0.0.1 --port 3001 --config config.json

4 Answers 4

1

apt install netbase in your container. it worked out for me.

1
  • This worked for me. I'm running cardano-node in a base debian container image.
    – nalyd88
    Mar 19, 2023 at 4:37
0

These logs look like an issue with you config.jason file in your public root section you are calling a service name that it can not find. Would need to see your config.jason file to comment more

2
0

Apparently the testnet does not work for cardano-node 1.35.3. I have to run cardano-node 1.35.2 to use the testnet

0

I had a similar issue. Have a look at the following answer, changing the host-addr worked in my case:

https://cardano.stackexchange.com/a/9203/7074

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.