I'm using Ubuntu 20.04 and trying to install cardano-wallet with this guide. I tried a few times and every time I got this error:

ouroboros-consensus-byron        > Registering library for ouroboros-consensus-byron-
Progress 461/475

--  While building package plutus-tx- (scroll up to its section to see the error) using:
      /root/.stack/setup-exe-cache/x86_64-linux-tinfo6/Cabal-simple_mPHDZzAJ_3.2.1.0_ghc-8.10.7 --builddir=.stack-work/dist/x86_64-linux-tinfo6/Cabal- configure --with-ghc=/root/.stack/programs/x86_64-linux/ghc-tinfo6-8.10.7/bin/ghc-8.10.7 --with-ghc-pkg=/root/.stack/programs/x86_64-linux/ghc-tinfo6-8.10.7/bin/ghc-pkg-8.10.7 --user --package-db=clear --package-db=global --package-db=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/pkgdb --libdir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/lib --bindir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/bin --datadir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/share --libexecdir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/libexec --sysconfdir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/etc --docdir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/doc/plutus-tx- --htmldir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/doc/plutus-tx- --haddockdir=/root/.stack/snapshots/x86_64-linux-tinfo6/7d9a5133e73e69eafb80db950076b4ec70696c4137ef4c6e05d111373f4a3891/8.10.7/doc/plutus-tx- --dependency=aeson=aeson- --dependency=base=base- --dependency=bytestring=bytestring- --dependency=containers=containers- --dependency=deepseq=deepseq- --dependency=filepath=filepath- --dependency=flat=flat-0.4.5-4g0HMvnhh6wwWCZXBuoYZ --dependency=ghc-prim=ghc-prim-0.6.1 --dependency=hashable=hashable- --dependency=lens=lens-4.19.2-jJTa5AeuDm5NTBTeWMq3U --dependency=memory=memory-0.15.0-12G9mJuoNajBX4ohDjVYqb --dependency=mtl=mtl-2.2.2 --dependency=plutus-core=plutus-core- --dependency=prettyprinter=prettyprinter-1.7.1-89YQ13YwDjX8F1jciVrjTL --dependency=serialise=serialise- --dependency=tagged=tagged- --dependency=tasty=tasty- --dependency=template-haskell=template-haskell- --dependency=text=text- --dependency=th-abstraction=th-abstraction- --dependency=th-compat=th-compat-0.1.3-5V8hDdHCkmaDnfC7yeUenV --exact-configuration --ghc-option=-fhide-source-paths
    Process exited with code: ExitFailure 1

How can I fix it?

  • Are there any more useful messages above what you have posted? Commented Apr 27, 2022 at 21:35
  • You might be on an old version of Cabal, I noticed 'Cabal-' in your error message. cardano-node wants version, wallet might be similar. Did you also build cardano-node as per the wallet guide suggestion? If so that will confirm that cabal etc is ok. cardano-node setup link (if needed): developers.cardano.org/docs/get-started/installing-cardano-node Commented Apr 27, 2022 at 23:02
  • @MC_Brisbane Thank you for replying. Sure I built cardano-node and have needed versions. cardano-node 1.34.1 - linux-x86_64 - ghc-8.10, git rev 73f9a746362695dc2cb63ba757fbcabb81733d23, cabal-install version, compiled using version of the Cabal library
    – Pavel R
    Commented Apr 27, 2022 at 23:43
  • Scroll up a few lines from the error message to get more details relating to 'plutus-tx'. Also, are you running as the same user that built the cardano-node? Could be some shared objects. PlanB - if you're in a hurry you could grab the binary instead of building it. Commented Apr 28, 2022 at 3:38
  • Working only under root, here is the full error.
    – Pavel R
    Commented Apr 28, 2022 at 7:55

1 Answer 1


I was able to reproduce your error on my Ubuntu 20.04.4 LTS (with 8GB RAM, no other Cardano code was on this machine).

Initially it failed at a different spot 'Progress 445/475' and re-running the build ended up like your situation eg:

plutus-tx                      > Configuring plutus-tx-
plutus-tx                      > Cabal-simple_mPHDZzAJ_3.2.1.0_ghc-8.10.7: Encountered missing or private     [<--- NOTE]
plutus-tx                      > dependencies:
plutus-tx                      > plutus-core:{plutus-core, plutus-core-testlib} ==
plutus-tx                      > 
Progress 7/21           

--  While building package plutus-tx- (scroll up to its section to see the error) using:
    Process exited with code: ExitFailure 1

Note the missing dependencies lines.

I decided to use the previous wallet version (not the latest), in case it was more stable ie v2022-01-18.

The below is what worked for me to get it to build ok:

  1. Stop some other processes to free up RAM if you only have 8GB like me.

  2. I installed libsodium, you probably won't need this step if you have built cardano-node successfully

  3. Start the whole download/build process over again in a new directory but this time use the previous stable code release eg git checkout v2022-01-18

  4. Run the build, it should complete eg stack build --test --no-run-tests

I don't have cardano-node on this machine so can not run the wallet as intended but cardano-wallet version looks ok:

cardano-wallet version
v2022-01-18 (git revision: a5085acbd2670c24251cf8d76a4e83c77a2679ba)

  • git checkout v2022-01-18 is really working for me. Great thanx!
    – Pavel R
    Commented Apr 28, 2022 at 8:34
  • Great, am pleased to hear it. I'm not sure of the actual root cause, but we might find that as other code in the repo gets updated over then next few days/weeks that it all comes right and plays together nicely again. Commented Apr 28, 2022 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.