1

I'm trying to build and install cardano-wallet on ubuntu according to https://developers.cardano.org/docs/get-started/installing-cardano-wallet/#building-and-installing-the-node

But once I run the below command,
stack build --test --no-run-tests

I'm getting this error.

Received ExitFailure 128 when running
Raw command: /usr/bin/git reset --hard f827a4321e42f528e25f6079f7af3eb18f10d391
Run from: /tmp/with-repo8046/cloned
Standard error:

fatal: Could not parse object 'f827a4321e42f528e25f6079f7af3eb18f10d391'.

Any idea?

6
  • What is your ubuntu version?
    – os11k
    Dec 11, 2021 at 17:45
  • Try maybe git fetch and then try one more time that command?
    – os11k
    Dec 11, 2021 at 18:37
  • Seems something is broken. :) I will try to reach out developers. Seems cardano-ledger repository don't have necessary commit.
    – os11k
    Dec 11, 2021 at 20:19
  • I'm getting exactly the same error here, at object f827a4321e42f528e25f6079f7af3eb18f10d391 (using Ubuntu 20.04.2)
    – Mauro
    Dec 11, 2021 at 21:24
  • 1
    I retried today and it worked.
    – Mauro
    Dec 13, 2021 at 22:36

1 Answer 1

1

This commit was referencing a pull request branch of cardano-ledger that was closed: jc/benchmark/1-29-0-with-time. A new branch was pushed to resolve this called cardano-wallet/deps-for-node-1.30.1

This is a weird oddity with GitHub where it will refuse to give you an archive for a commit, even if it's aware of it if it's been orphaned and no longer exists in an open branch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.