2

I'm trying to implement the 4th option of the starter pack setup using docker/vscode on my mac M1. I followed the instructions carefully from the github repository, but I'm getting errors. I'm new to cabal so please forgive me if I'm making a basic error.

When I run the cabal build command (from my regular mac terminal, not within vscode container), I get the following message at the end:

Warning: Requested index-state2021-08-14T00:00:00Z is newer than
'hackage.haskell.org'! Falling back to older state (2021-08-13T22:58:51Z).
Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: Win32-network-0.1.0.0 (user goal)
[__1] trying: base-4.13.0.0/installed-4.13.0.0 (dependency of Win32-network)
[__2] next goal: base-deriving-via (user goal)
[__2] rejecting: base-deriving-via-0.1.0.0 (conflict:
base==4.13.0.0/installed-4.13.0.0, base-deriving-via => base>=4.14)
[__2] fail (backjumping, conflict set: base, base-deriving-via)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, Win32-network, base-deriving-via

I tried cabal update and got the following:

Downloading the latest package list from hackage.haskell.org
To revert to previous state run:
    cabal v2-update 'hackage.haskell.org,2022-01-11T17:07:35Z'

(Note that I accidentally ran cabal update before opening the container in vscode the first time. I'm assuming this doesn't matter).

I'm not sure if it's installed correctly or not. I'm surprised that it's looking for Win32, considering this is a mac.

Finally, I tried testing the PAB example to see if I could simply ignore the previous errors, and got this:

Warning: Requested index-state2021-08-14T00:00:00Z is newer than
'hackage.haskell.org'! Falling back to older state (2021-08-13T22:58:51Z).
Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: Win32-network-0.1.0.0 (user goal)
[__1] trying: base-4.13.0.0/installed-4.13.0.0 (dependency of Win32-network)
[__2] next goal: base-deriving-via (user goal)
[__2] rejecting: base-deriving-via-0.1.0.0 (conflict:
base==4.13.0.0/installed-4.13.0.0, base-deriving-via => base>=4.14)
[__2] fail (backjumping, conflict set: base, base-deriving-via)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: base, Win32-network, base-deriving-via

Any help would be appreciated.

1 Answer 1

0

Did you try to run the command:

cabal v2-update 'hackage.haskell.org,2022-01-11T17:07:35Z'

→ This is communicated after your update command and should install the correct version.

1
  • I tried this with no effect. It said it was downloading the latest package, and then displayed the exact same message about reverting to 'hackage.haskell.org,2022-01-11T17:07:35Z'. I think nothing actually happened. Jan 11, 2022 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.