7

It may help to use IOHK's binary caches. You can set these up globally for your system by adding/creating these lines in /etc/nix/nix.conf: substituters = https://hydra.iohk.io https://iohk.cachix.org https://cache.nixos.org/ trusted-public-keys = hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ= iohk.cachix.org-1:DpRUyj7h7V830dp/i6Nti+NEO2/...


3

So it looks like I initially built on the master branch by mistake. Switching to the correct branch and recompiling didn't help the situation. I reset my WSL instance of Ubuntu and started again, more carefully this time. Everything worked as it should.


3

This is documentation drift. Those two applications have moved to plutus-apps. If you do the same exact steps cloning plutus-apps instead of plutus repository, it will work.


2

It looks like those folders are not in the git repo. I am running into same problem. I am following instructions for MacOS from here: https://docs.plutus-community.com/docs/setup/MacOS.html And didn't realize it until i tried to build the playground client and server. When i try to build with this command: $ nix-build -A plutus-playground.client --option ...


2

There are multiple different types of nix.conf files in the $PATH, even when I made one globally. So What I initial did was replace all of them with the IOHK's binary caches, and from there it worked.


1

Fixed. I had the Cardano node previously installed which involves compiling and installing libsodium. What I did was go into the libsodium folder and sudo make libsodium uninstall Then re-ran nix installation and now I get a nix-shell.


1

So the solution was simply to install nix-darwin https://github.com/LnL7/nix-darwin simply follow the instruction on the github page above, and now I can access my nix-shell


1

You appear to be having issues resolving the dependencies for that particular build of Plutus. In fact, all Cardano builds depend on libsystemd (on Linux). If you have incompatible versions of libsystemd and libsystemd-journal you get the rejection that you're having in regards to the dependencies. It appears Plutus also depends on these packages. Please see ...


1

Try in the nix-shell try this: cabal update cabal build btw: first time building with cabal can take up some time


Only top voted, non community-wiki answers of a minimum length are eligible