Questions tagged [pab]

the Plutus Application Back-end

Filter by
Sorted by
Tagged with
0 votes
2 answers
50 views

Why can't the PAB webserver find a socket in PAB-Nami demo?

I'm trying to run the PAB-Nami simple demo in the Plutus Apps repo. When I run the PAB, either using cabal or with the nix-shell script, I'm getting the error: plutus-pab-nami-demo: Network.Socket....
Mitchell Turner's user avatar
0 votes
1 answer
66 views

Getting TypeError: EC is not a constructor running pab-nami

When running npm, start inside a nix-shell of plutus-apps/plutus-pab-executables/demo/pab-nami/client
Jonathan Fishbein's user avatar
0 votes
1 answer
63 views

cardano-wallet for pab-local-cluster

Does anyone have an example of how to execute the cardano-wallet CLI for the pab-local-cluster in plutus-apps (tag: v2022-01-17)? I can get access to to the local wallet server APIs, but I need the ...
lley154's user avatar
  • 297
0 votes
1 answer
73 views

Plutus-starter - cannot start contract instance

I am following the link below. I've successfully built the docker image (literally had to upgrade to 32 GB of RAM, it used 15 GB at peak RAM usage during cabal build). I have the PAB server running ...
projection-error's user avatar
0 votes
1 answer
81 views

Is IOG’s PAB going to be deprecated?

I wonder if we should consider the official PAB deprecated.
kindofdev's user avatar
  • 1,304
0 votes
1 answer
61 views

start-cluster - Command failed: genesis create - */genesis.alonzo.spec.json: openBinaryFile: does not exist (No such file or directory)

After cloning latest cardano-node and running nix-shell successfully I get an error running start-cluster and different error if I run with sudo: Do I need to download the latest genesis jason file? ...
Deano's user avatar
  • 100
0 votes
1 answer
18 views

Can someone help to understand how to use handleChainIndexClient?

I'm not guru with Eff system under Haskell. What i got that method could contains the constraints for monad that should be used with. module ChainIndexHelper where import Plutus.ChainIndex.Client ...
ViktorYasterbov's user avatar
0 votes
1 answer
73 views

how to query the chain index tx endpoint?

The following curl is constructed via swagger that says it just needs the string, but this fails. What am I doing wrong? $curl -X 'POST' \ > 'http://localhost:9083/tx' \ > -H 'accept: ...
waalge's user avatar
  • 403
0 votes
0 answers
44 views

Cannot send a transaction using Plutus

I get the following error when I try to send a transaction that locks some ADA in a UTXO: [pab:Warning:41] [2022-01-28 11:58:42.88 UTC] WalletClientError "ConnectionError (HttpExceptionRequest ...
Attilah's user avatar
  • 431
0 votes
1 answer
23 views

Can GTK libraries used with Plutus?

Interested in GUI interfaces, is their restriction's in using GTK Haskell libraries with Plutus. Am only starting on Journey so wanted general feedback that might help guide me down right path.
shad786's user avatar
0 votes
1 answer
97 views

Webpack warning when starting plutus-playground-client

I am getting a warning when I run npm start on the plutus-playground-client: ℹ 「wds」: webpack output is served from / ℹ 「wds」: Content not from webpack is served from /home/datapool/plutus-apps/plutus-...
d_fajardo's user avatar
  • 198
0 votes
1 answer
117 views

Does anyone else have trouble syncing to the PAB end to end testnet?

Plutus PAB Testnode git checkout v2021-11-05 Following the instructions on the readme file leads me to a testnet node that is stuck due to a corrupt block error. [relay2:cardano.node.ChainDB:Error:34] ...
Logical Mechanism's user avatar
0 votes
1 answer
51 views

Hooks empty after calling endpoint

I'm finding it difficult figuring out the cause of this hiccup. When I create an instance of a contract, the hooks are populated, but after calling an endpoint, the hooks list becomes empty. Status of ...
Aoaddeola's user avatar
  • 815

1
2