Questions tagged [m1]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
6 views

setup a Plutus project use haskell.nix Error on Mac M1

I'm trying to set up a Plutus project with flake on my Macbook by IOHK document I did the following steps: create default.nix enter command nix flake init --template templates#haskell-nix --impure ...
  • 1
0 votes
1 answer
65 views

Cardano-Node 1.35.0 Build Error on M1 Mac

I'm trying to install cardano-node version 1.35.0 on my M1 Mac. It worked (somewhat) previously with version 1.34.2 using LLVM. Currently I am running into this error when it tries to build ...
0 votes
2 answers
80 views

Cardano-node and cli install "llvm error"

I'm facing error with the llvm install, i tried all the llvm@11;12;13 even the 14 and still a come across error when i move to step "cabal build all" my set up is a M1 pro. Help! thank you
1 vote
1 answer
145 views

Error on Cabal Build: Failed to build plutus-core-0.1.0.0

Following the instructions from https://github.com/input-output-hk/marlowe-pioneer-program, yet on a Mac M1, running cabal build from within /marlowe-pioneer-program/code main generates 2 errors: ...
0 votes
1 answer
50 views

AMD64 Error Warning When Setting Up Grapgql Docker in Mac M1

I am following the following guide to set up graphql on my M1 Mac. https://github.com/input-output-hk/cardano-graphql#overview. All the containers are up and running but i can't visit local host to ...
3 votes
1 answer
115 views

Issue compiling pab-local-cluster on M1 processor

I have been trying to get the new PAB beta release to compile on my M1 Mac and have run into an issue. Build log ( /Users/isaacpadberg/.cabal/logs/ghc-8.10.4/crdn-nd-1.30.0-8154d373.log ): Configuring ...
9 votes
5 answers
2k views

Installing Cardano-node on an M1 Mac

I am trying to get a cardano node started on a Mac with the new M1 chip. Ive looked through the Installing a Cardano-node walk-through and found that they specify that the Mac install is for Intel ...