Skip to main content

Questions tagged [ghc]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
76 views

Error when trying to build my Plutus project

I am getting the following error after trying to execute cabal build: cabal: Could not resolve dependencies: [__0] next goal: cardano-crypto-class (user goal) [__0] rejecting: cardano-crypto-class-2.0....
Falcon Stakepool's user avatar
1 vote
1 answer
108 views

Error when compiling cardano-node 1.35.5

I am getting the following error when trying to compile the new version of the cardano-node: Resolving dependencies... Error: cabal: Could not resolve dependencies: [__0] trying: cardano-api-1.35.5 (...
Falcon Stakepool's user avatar
0 votes
0 answers
12 views

How do I change the -with-rtsopts flags when I execute cardano-node?

I want to specify some extra flags like --nonmoving-gc and -N (with the right amount of CPU cores that I want my cardano-node to execute in - my server has 16 CPU cores) in my +RTS configuration. What ...
Falcon Stakepool's user avatar
0 votes
2 answers
35 views

Plutus-tx on XEON v2

I am trying to compile plutus script on 'Intel(R) Xeon(R) CPU E5-2680 v2' machine. I initialized nix flake from input-output-hk/iogx haskell template (tried with ghc96 and ghc92), entered development ...
amakarov's user avatar
  • 101
0 votes
1 answer
46 views

Cardano Node Compiler Error libsodium Fedora

for some reason i'm unable to compile cabal projects related to cardano projects on this system. not sure what could of changed recently as aside from recent system updates i haven't changed much. or ...
Kunikos's user avatar
  • 13
0 votes
1 answer
24 views

Nix error trying to install correct GHC version for Plutus

As recommended by Haskell/Nix expert lan Burzynski, I'm trying to use Nix install the correct GHC version for Plutus as follows: nix shell nixpkgs#haskell.compiler.ghc8107BinaryMinimal nixpkgs#cabal-...
Eric's user avatar
  • 85
0 votes
0 answers
79 views

Error when trying to build my Plutus project using nix-shell

I am getting the following error after running cabal build using nix-shell: cabal: Could not resolve dependencies: [__0] next goal: Win32-network (user goal) [__0] rejecting: Win32-network-0.1.1.0/...
Falcon Stakepool's user avatar