1

I am getting the following error after trying to execute cabal build:

cabal: Could not resolve dependencies:
[__0] next goal: cardano-crypto-class (user goal)
[__0] rejecting: cardano-crypto-class-2.0.0.0.1/installed-iw7NtuXmRKLDXiVT5sxh
(constraint from user target requires ==2.0.0)
[__0] rejecting: cardano-crypto-class-2.0.0 (conflict: pkg-config package
libsodium-any, not found in the pkg-config database)
[__0] fail (backjumping, conflict set: cardano-crypto-class)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: cardano-crypto-class

I am using cabal 3.6.2.0 and ghc 8.10.7

1 Answer 1

2

You are missing libsodium :

[__0] rejecting: cardano-crypto-class-2.0.0 (conflict: pkg-config package
libsodium-any, not found in the pkg-config database)

The way I get around this is sudo apt install libsodium-dev and then create a top level file cabal.project.local containing:

package cardano-crypto-praos
  flags: -external-libsodium-vrf

Pretty sure this is documented somewhere in the cardano-node repository.

3
  • 1
    It is documented here: github.com/input-output-hk/cardano-node/blob/1.35.5/doc/…
    – james
    Feb 2, 2023 at 18:02
  • It is documented, but it no longer works. Builds are failing with the hack in place. Nov 5, 2023 at 1:32
  • I just tried it and it works for me. What specifically is the problem you are seeing. Probably worth asking that as a new question. You need to specify what steps you are taking and what the error is. Nov 5, 2023 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.