0

I am using following command to query node. ./cardano-cli query utxo --address $(cat payment.addr) --testnet-magic 1097911063 Getting the Faucets in preview testnet by the following site https://docs.cardano.org/cardano-testnet/tools/faucet The funding gets successful, also i can see the transaction hash on https://preview.cexplorer.io/tx ,But not getting faucets on node query. Although my node is also synced to 64% with Alonzo era. Kindly guide me what i am missing. Also i am using the latest cardano-node version ie. 1.35.4

1 Answer 1

1

First, in order to be able to query your address after you just used the faucet, the node must be in sync (100%). The version 1.35.4 is correct, it is the only one that will sync your node to 100%. Second, if you are on the preview testnet, the testnet magic is 2. The testnet magic 1097911063 is for the legacy testnet.

6
  • Hi thanks for your answer, ill check it again when it gets 100% synced. Also i checked my testnet magic from db created which shows me 1097911063. And if i query the node with magic 2 then it gives me error of "cardano-cli: HandshakeError (Refused NodeToClientV_13 "version data mismatch: NodeToClientVersionData {networkMagic = NetworkMagic {unNetworkMagic = 1097911063}} /= NodeToClientVersionData {networkMagic = NetworkMagic {unNetworkMagic = 2}}")"
    – duaa azhar
    Dec 23, 2022 at 8:15
  • If your magic in the db folder is 1097911063, then you are on the legacy testnet, not on preview. Dec 23, 2022 at 9:12
  • To switch to preview, you need to stop the node, download the configuration files for preview from here: book.world.dev.cardano.org/environments.html, delete the db folder and start your node. Also, 1.35.4 will never sync the legacy testnet to 100%. Only 1.35.2 will sync it to 100%. Dec 23, 2022 at 9:14
  • Yah, I have tried the prepod testnet also, but its syncing doesn't go beyond 0.01% even after a whole day. With that syncing speed i am unable to get any faucets. Can you please recommend its solution. I have also tried cardano 1.35.3 (preview and also preprod), but again its not syncing enough then how can i get faucets and proceed with that?
    – duaa azhar
    Dec 24, 2022 at 16:59
  • Syncing on preview and preprod should be a matter of minutes, you are probably doing something wrong. For preview and preprod use 1.35.4, 1.35.3 will still go for a while for preprod, but not for preview. You should check the logs to see what the problem is. If you are not starting your node as a systemd service, take a look at the tutorial I wrote here: apexpool.gitbook.io/stake-pool-scripts/running-a-cardano-node To see the logs if you set it like I described, run: journalctl -f -n 50 -u cardano-node.service Dec 24, 2022 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.