0

When building cardano-node-1.35.4 using

git checkout tags/1.35.4
cabal update
cabal build all

I get the following error

cabal: Failed to build tx-generator-2.2 (which is required by

test:tx-generator-test from tx-generator-2.2 and exe:tx-generator from

tx-generator-2.2).

Upon scrolling up a few lines, I see this

src/Cardano/Benchmarking/Script/Setters.hs:40:1: error:

    • Illegal constraint: c NumberOfInputsPerTx

        (Use ConstraintKinds to permit this)

    • In the instance declaration for

        ‘Data.Constraint.Extras.Has c_a3mLE Tag’

   |

40 | deriveArgDict ''Tag

   | ^^^^^^^^^^^^^^^^^^^

Can someone please help me understand what this error means and on how to solve this? Thanks in advance.

2 Answers 2

2

I think between CHaP movements and upstream updates the build process has started failing for 1.35.4, they've been fixed since on master branch. But for visibility of those using 1.35.4 to build:

  1. Failed to build tx-generator-2.2 => This error itself would not prevent you to build cardano-node and cardano-cli binaries.
  2. For those who receive an error with openssl, they'd need to modify cabal.project file as per this issue.
  3. cabal install (running as-is for any component) was broken on that tag, fixed later on master
4
  • Thank you for your response. I will try this out. Yes, it wouldn’t prevent us from building binaries but the nodes won’t sync up to preview/prepped after that. That is the major issue am facing.
    – Srinath
    Dec 22, 2022 at 9:45
  • Sync of node should work fine on preview/preprod once node binary is built, and is actually used for node startup (you can confirm running node version via logs as well if using ScJson)
    – RdLrT
    Dec 22, 2022 at 12:55
  • Hi @RdLrt, Sadly adjusting the cabal.project file did not work. However, I didn't receive any error on the master branch.
    – Srinath
    Dec 29, 2022 at 15:26
  • You should not use master branch, it may often contain changes that may not be supported by current network[s] or tools
    – RdLrT
    Dec 30, 2022 at 7:14
0

What version of ghc are you using? Currently the only supported version is ghc-8.10.*.

Work is being done to support ghc-9.2.* and when that is supported across the complete stake, then support for ghc-9.10.* will be dropped.

1
  • 1
    Hi there, Thank you for your response. I am using the 8.10.7.
    – Srinath
    Dec 22, 2022 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.