0

I'm trying to run graphql following these instructions. I do already have dbsync & cnode running for the preprod network, but I get this error:

{"name":"cardano-graphql","hostname":"DESKTOP-I38CEOE","pid":4332,"level":20,"msg":"Establishing connection to cardano-node: Attempt 3 of 101, retrying...","time":"2022-09-25T12:09:20.800Z","v":0}

Any idea what could be the issue? Maybe I need to edit/add some env var for the CNODE?

error screenshot

1 Answer 1

-1

Well I don't know for sure what is going on and would require more information to practically help. But I would investigate how graphQL is getting the node's params from. Then check that those are correct, then make sure the host where graphQL is running from can connect to the node's host. If both node and gQL run on the same host it is likely a parameter issue (port, socket).

3
  • thank you for your answer, actually yes i tried to look if there is anything regarding how it connect to the node ... but found nothing .. im new to this. Sep 25, 2022 at 19:32
  • no worries, I'll try to find some time today to follow the instructions above, I'll revert back with my findings, although I'm not using cnode it will probably help me understand where gQL is getting the node's details from. Actually could you print out your ${CNODE_HOME}/files/config.json file please? Sep 26, 2022 at 8:28
  • hello this is the config file : justpaste.it/7nwn6 Sep 29, 2022 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.