I have created my own token and I have added a Cardano Token Registry specifying that the token has 6 decimals places. My entry looks exactly like the Minswap's token entry, but the difference is that, when I want to send a transaction, I don't have the possibility to add decimal places, like I do have on the Minswap token.

Is there anything else I should do so my token shows like this:

enter image description here

2 Answers 2


Not sure if Eternl has this implemented, but there is a proposal that adds this token information to the metadata of the minting transaction:


Minswap doesn't follow it, but Sundae does. Here's an example under Label 20:


Probably worth a try.

Also, if your token is not correctly displayed in Eternl, you can click the "update" button (marked in red below), to re-fetch the data of your token from the Cardano Token Registry:

enter image description here

  • I tried also with that but it doesn't work. The problem is only in Eternl, in Nami and in Cardanoscan I can visualise the right amount of decimal places. Sep 15, 2022 at 3:41
  • 1
    in discord it is suggested to "press the little update icon button to fetch the new registry data". Couldn't try it myself though
    – sean
    Sep 15, 2022 at 11:43

Did you register your token at CFtoken registry ? You can specify decimals as part of JSON you register on that repo.

  • 1
    Yes, I did, my entry looks exactly like the Minswap entry. Sep 3, 2022 at 4:05
  • Any other suggestion? Because I still have this issue. The problem appears to be only with Eternl, in Nami it works fine. Sep 15, 2022 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.