0

I'm trying to install cardano-node version 1.35.0 on my M1 Mac. It worked (somewhat) previously with version 1.34.2 using LLVM. Currently I am running into this error when it tries to build threepenny-gui:

dlopen(/Users/stefan/.cabal/store/ghc-8.10.7/lib/libHSHsOpnSSL-0.11.7.2-e201b3b3-ghc8.10.7.dylib, 0x0005): symbol not found in flat namespace (_DSA_free)

It looks like the issue is with the openSSL library with cabal is missing a required symbol. Does anyone have any suggestions on how to make this available?

2

1 Answer 1

1

The issue had to do with the openSSL library I was using and was resolved in the instructions provided here: https://github.com/mallapurbharat/cardano-tx-sample/blob/main/0_installation/macos_m1_process.md

This included including the homebrew openssl library. Specifically here and here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.