0

When running cabal build or cabal repl in the core/week04 folder I get the following error message when building the playground-common-0.1.0.0 package:

src/Auth.hs:130:41: error:
    Not in scope: type constructor or class 'JWT.EncodeSigner'
    Module 'Web.JWT' does not export 'EncodeSigner'
    |
130 |         { _configJWTSignature       :: !JWT.EncodeSigner
    |                                         ^^^^^^^^^^^^^^^^ 

I am in the correct branch in the plutus-apps repo as per the cabl.project file in code/week04. I've run cabal update and it was successful.

Does anyone have any ideas how to resolve this?

2
  • 1
    Do you run cabal from nix-shell? Feb 17 at 9:02
  • 1
    yes, I do. It appears the issue was that I ran nix-shell under an old commit (for week 3) and restarting the shell after the commit was changed allowed cabal build to run
    – wildcatmik
    Feb 17 at 21:02

1 Answer 1

2

Be sure to do a git pull for both 'plutus-master' and 'plutus-pioneer-program'. Then set the right git-checkout tag (of the week's cabal project file) Restart nix-shell so it builds the 'plutus-master', after that you can do the following to resolve missing dependencies in the 'week' folder:

  • cabal clean
  • cabal update
  • cabal build
  • cabal repl

This should work

1
  • 2
    Thanks, the key here for me was to restart the nix-shell. Once I did this everything flowed as expected.
    – wildcatmik
    Feb 18 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.