0

I am trying to delegate a wallet through cardano-cli for most it was going okay, but more recently even though I get the message Transaction successfully submitted. after submitting the transaction, no money gets transferred. The same happens when I try to delegate the wallet.

I noticed that on the cardano-node logs I get something that makes me think some sort of ofrk is happening? Ignoring block already in DB

[x-XP:cardano.node.ChainDB:Info:47551] [2022-02-07 13:30:47.64 UTC] before next, messages elided = 94461957158106
[x-XP:cardano.node.ChainDB:Info:47551] [2022-02-07 13:30:47.64 UTC] Ignoring block already in DB: ce7b38a4b05435f4ebe07e1ba52154b6db7131bd062c7809bc5d4ef29b27f3f3 at slot 52674352
[x-XP:cardano.node.Mempool:Info:47597] [2022-02-07 13:30:49.49 UTC] fromList [("tx",Object (fromList [("txid",String "36f15e82")])),("kind",String "TraceMempoolAddedTx"),("mempoolSize",Object (fromList [("bytes",Number 399.0),("numTxs",Number 1.0)]))]

[x-XP:cardano.node.ChainDB:Info:35] [2022-02-07 13:37:17.56 UTC] Block fits onto some fork: ebf7869a4b082c3d4b2ec60d14f2e8d8f803b9e5a3ab9cd7536927dc9a2b8227 at slot 52674744
[x-XP:cardano.node.ChainDB:Notice:35] [2022-02-07 13:37:17.66 UTC] Switched to a fork, new tip: ebf7869a4b082c3d4b2ec60d14f2e8d8f803b9e5a3ab9cd7536927dc9a2b8227 at slot 52674744


I tried to delete the entire db and resync the entire cardano-node but as soon as I tried to make a transaction the same as above happenend.

How can I fix this so to have successful transactions again? what coudl I be doing wrong?

1
  • actually it seem the transactions went through now, so I guess it was indeed a bad database, not sure why it still says Ignore block though. Possible that the problem I had earlier was because I was sending transactions in parallel rather than sequentially and made me fork? Feb 7, 2022 at 13:42

1 Answer 1

0

Likely this was congestion in getting the transaction adopted rather than the db state being an issue. As for Ignore block, this is normal consensus layer stuff. Another node on network said I have this block, and the node looked at it's current state and decided it's fork was better than the one that block fit on so it never asked for the block.

2
  • oh yes, seeing all the discussion developing right now on certain type of transaction having a preferential way with SPOs makes it more clear my problems where transactions go through only every so often. I just told that once submitted, the Tx was taken, even if it was going to take more time.. increasing TTL could help? Feb 7, 2022 at 14:48
  • SPOs cannot influence the order of the transactions. Most probably what happened is that your TTL wasn't long enough and the deadline slot no had already been surpassed once your transaction was being processed. "Transaction successfully submitted" just means that the transaction passed the initial checks (balanced values, appropriate signatures, sufficient fee, etc) and has been added to the mempool. However, once the transaction actually starts being processed there are other on-chain checks that are performed, such as valid-before, valid-after and any plutus validators.
    – grim_i_am
    Apr 21, 2022 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.