0

I have a node that I had run a few months ago and then stopped using for a long time, a few days ago I decided to start the node again, the node started syncing with no issues but midway trough it all the Terminal app (I'm using a Mac) stopped responding, so after seeing it for a while like that (and after all the other apps stopped responding too) I decided to turn off the computer thinking I could start the process again, but then today I got this:

[yeshco:cardano.node.ChainDB:Info:5] [2022-02-01 00:39:49.68 UTC] Opened imm db with immutable tip at 9ff948e88999a5de60fa92694c55e764ef4b3985dbcf1c88d7442fdcca576ed4 at slot 40555639 and chunk 1877

Shutting down..
FsError {fsErrorType = FsResourceDoesNotExist, fsErrorPath = /Volumes/2T WD NEGRO/Crypto/Cardano/db/volatile/blocks-6266.dat, fsErrorString = "No such file or directory", fsErrorNo = Just (Errno 2), fsErrorStack = CallStack (from HasCallStack):
  prettyCallStack, called at src/Ouroboros/Consensus/Storage/FS/API/Types.hs:297:23 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.API.Types
  ioToFsError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:88:41 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.IO
  handleError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:84:23 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.IO
  rethrowFsError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:37:21 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.IO
  hOpen, called at src/Ouroboros/Consensus/Storage/FS/API.hs:152:43 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.API
  withFile, called at src/Ouroboros/Consensus/Util/CBOR.hs:227:7 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Util.CBOR
  withStreamIncrementalOffsets, called at src/Ouroboros/Consensus/Storage/VolatileDB/Impl/Parser.hs:67:5 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.VolatileDB.Impl.Parser, fsLimitation = False}

cardano-node: FsResourceDoesNotExist for /Volumes/2T WD NEGRO/Crypto/Cardano/db/volatile/blocks-6266.dat: No such file or directory at CallStack (from HasCallStack):
  prettyCallStack, called at src/Ouroboros/Consensus/Storage/FS/API/Types.hs:297:23 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.API.Types
  ioToFsError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:88:41 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.IO
  handleError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:84:23 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.IO
  rethrowFsError, called at src/Ouroboros/Consensus/Storage/FS/IO.hs:37:21 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.IO
  hOpen, called at src/Ouroboros/Consensus/Storage/FS/API.hs:152:43 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.FS.API
  withFile, called at src/Ouroboros/Consensus/Util/CBOR.hs:227:7 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Util.CBOR
  withStreamIncrementalOffsets, called at src/Ouroboros/Consensus/Storage/VolatileDB/Impl/Parser.hs:67:5 in rbrs-cnsnss-0.1.0.0-0b62aa4c:Ouroboros.Consensus.Storage.VolatileDB.Impl.Parser

And I can't sync it.
I would be very thankful if somebody can help!

2 Answers 2

0

The first thing I'd check is if your disk is full. A lot of unix programs will error failing to create a file because there's no disk space and report it as no such file or directory...

The next thing would be that the user running node has permission to write to the state directories. If you ran it as a service user in the past and now are running it as your normal user (or if you did something bad like running node with sudo), fixing permissions with chown might do the trick.

Next thing I'd do is update the node to latest and remove only the ledger and volatile directories. This will force a ledger rebuild that could take a while, so just be patient. While it's doing the rebuild if it detects any corruption in immutable the node should truncate to that point and start syncing. Leaving immutable will significantly reduce sync time if there's no corruption early in the chain data.

1
  • Thanks!, I was going to ask this before but how do you update the node, I tried to clone the repository again on a copy I made but my node is still 1.29.0?
    – yeshcO
    Feb 1 at 22:23
1

It looks like the on disk storage is corrupted. If you also have not run it in a couple of months you probably need to upgrade your node version.

Upgrading the software may help with the other problem, otherwise delete all the storage and resync the node.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.