1

When I run cabal repl in the week01 folder I get an error message that states the following

*/plutus-pioneer-program/code/week01/dist-newstyle:
    createDirectory: permission denied (Permission denied)

I am not sure how to resolve this error. The command looks to create a directory but the build does not have permissions to create that directory.

Any help you can provide is appreciated.

Thank you

5
  • 2
    Can you please provide steps to reproduce this failure? Which Operating System, which architecture, which repo cloned, which ref, and which command invocations?
    – angerman
    Commented Jan 26, 2022 at 2:30
  • Thank you for your interest in help resolve this issue.
    – SidneyN
    Commented Jan 27, 2022 at 15:58
  • 1
    Operating System VM VirtualBox running Ubuntu 20.04.3 LTS Steps I take Intiate nix-shell in the plutus-apps directory Navigate to home/user/plutus-apps/plutus-pioneer-program/code/week01 or home/user/plutus-apps/plutus-pioneer-program/code/week02 At prompt enter: cabal repl This is where I get the error message.
    – SidneyN
    Commented Jan 27, 2022 at 16:06
  • Do you have enough memory? Running all this stuff with require at least 8GB. Commented Jan 30, 2022 at 23:44
  • Yes, I believe I have about 12Gigs. The problems seems to be tied to not having permissions to create files/directories during an installation. When I run cabal repl, it throws an error protesting that cabal repl does not have permission to create directory dist-newstyle.
    – SidneyN
    Commented Feb 1, 2022 at 0:53

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.