1

2 days stucked with this (running on Ubuntu):

[nix-shell:~/plutus-pioneer-program/code/week01]$ cabal build 
Warning: Requested index-state 2021-10-20T00:00:00Z is newer than 'hackage.haskell.org'! Falling back to older state (2021-10-19T23:39:06Z).
Resolving dependencies... cabal: Could not resolve dependencies:
[__0] trying: Win32-network-0.1.0.0 (user goal)
[__1] trying: base-4.14.1.0/installed-4.14.1.0 (dependency of Win32-network)
[__2] trying: lobemo-scribe-systemd-0.1.0.0 (user goal)
[__3] next goal: libsystemd-journal (dependency of lobemo-scribe-systemd)
[__3] rejecting: libsystemd-journal-1.4.5 (conflict: pkg-config package libsystemd>=209, not found in the pkg-config database)
[__3] rejecting: libsystemd-journal-1.4.4 (conflict: base==4.14.1.0/installed-4.14.1.0, libsystemd-journal => base>=4.6 && <4.13)
[__3] skipping: libsystemd-journal-1.4.3, libsystemd-journal-1.4.2, libsystemd-journal-1.4.1, libsystemd-journal-1.4.0, libsystemd-journal-1.3.4, libsystemd-journal-1.3.3, libsystemd-journal-1.3.1, libsystemd-journal-1.3.0, libsystemd-journal-1.2.0, libsystemd-journal-1.1.0, libsystemd-journal-1.0.0 (has the same characteristics that caused the previous version to fail: excludes 'base' version 4.14.1.0)
[__3] fail (backjumping, conflict set: base, libsystemd-journal, lobemo-scribe-systemd) After searching the rest of the dependency tree exhaustively, these were the goals I've had most trouble fulfilling: base, libsystemd-journal, lobemo-scribe-systemd, Win32-network Try running with --minimize-conflict-set to improve the error message.

After searching the rest of the dependency tree exhaustively, these were the goals I've had most trouble fulfilling: base, libsystemd-journal, lobemo-scribe-systemd

1
  • In my case, I needed to put a base dependency version constraint in my cabal file: base ^>=4.14.1.0.
    – Buk
    Mar 2 at 15:32

2 Answers 2

0

the coresponding version for you can find there

$cd ~/code/haskell/plutus-pioneer-program/code/week01/ $less cabal.project

and there is a tag with right version

enter image description here

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jan 22 at 10:57
0

I received this error when running nix-shell from the plutus repository. To fix I exited that nix-shell, navigated to plutus-apps repository, and checked out the appropriate hash from the cabal.project file found in the cabal.project file. Then ran nix-shell from plutus-apps instead of plutus.

source-repository-package
  type: git
  location: https://github.com/input-output-hk/plutus-apps.git
  tag: 41149926c108c71831cfe8d244c83b0ee4bf5c8a
  1. $> cd <projects-dir>/plutus-apps
  2. $> git checkout 41149926c108c71831cfe8d244c83b0ee4bf5c8a
  3. $> nix-shell
  4. $> cd ../plutus-pioneer-program/code/week01
  5. $> cabal repl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.