0

I want to open the English Auction example. I was looking for it on the playground, but couldn't find it. Where did I go wrong?

First I have checked out the commit with SHA1 hash 41149926c108c71831cfe8d244c83b0ee4bf5c8a in the plutus-apps repo. Then I have build the playground server with nix-build -A plutus-playground.server as was suggested in a hint on the IOHK discord server (no link unfortunately, since not accessible from everywhere). I do not know what this did, but I remember it worked. Then I opened another terminal and inside this same repo I ran nix-shell and then changed directory to the plutus-playground-client. I ran plutus-playground-server, which seemed to have started the server without any mentionable warnings or errors:

$ plutus-playground-server
plutus-playground-server: for development use only
[Info] Running: (Nothing,Webserver {_port = 8080, _maxInterpretationTime = 80s})
Initializing Context
Initializing Context
Warning: GITHUB_CLIENT_ID not set
Warning: GITHUB_CLIENT_SECRET not set
Warning: JWT_SIGNATURE not set
Interpreter ready

Then I opened another terminal window, navigated to the plutus-apps repo again, ran nix-shell. cd-ed into the plutus-playground-client again and ran npm run start, which resulted in this output:

$ npm run start

> plutus-playground-client@1.0.0 start /home/myname/plutus-apps/plutus-playground-client
> plutus-playground-generate-purs && npm install && npm run install:spago && npm run build:webpack:dev

[Info] Running: (Nothing,PSGenerator {_outputDir = "generated"})
The following purescript packages are needed by the generated code:

  - plutus-playground-client
  - purescript-argonaut-codecs
  - purescript-either
  - purescript-enums
  - purescript-lists
  - purescript-maybe
  - purescript-newtype
  - purescript-ordered-collections
  - purescript-prelude
  - purescript-profunctor-lenses
  - purescript-tuples
  - web-common

Successfully created your PureScript modules!

Successfully created your servant API purescript functions!
Please make sure you have purescript-servant-support and purescript-bridge-json-helpers installed

Done: generated
npm WARN ajv-errors@1.0.1 requires a peer of ajv@>=5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ajv-keywords@3.5.2 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
npm WARN monaco-emacs@0.2.2 requires a peer of monaco-editor@^0.14.0 || ^0.15.0 || ^0.16.0 || ^0.17.0 || ^0.18.0 || ^0.19.3 || ^0.20.0 but none is installed. You must install peer dependencies yourself.
npm WARN plutus-playground-client@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

audited 752 packages in 4.172s

42 packages are looking for funding
  run `npm fund` for details

found 29 vulnerabilities (2 low, 17 moderate, 10 high)
  run `npm audit fix` to fix them, or `npm audit` for details

> plutus-playground-client@1.0.0 install:spago /home/myname/plutus-apps/plutus-playground-client
> spago install


> plutus-playground-client@1.0.0 build:webpack:dev /home/myname/plutus-apps/plutus-playground-client
> webpack-cli serve --progress --inline --hot --mode=development --node-env=development

10% building 0/1 entries 0/0 dependencies 0/0 modulesℹ 「wds」: Project is running at https://localhost:8009/
ℹ 「wds」: webpack output is served from /
ℹ 「wds」: Content not from webpack is served from /home/myname/plutus-apps/plutus-playground-client/dist
⚠ 「wdm」: WARNING in Src   Lib    All 
Warnings   0     0/28   0/28
Errors     0     0      0

70 WARNINGS in child compilations (Use 'stats.children: true' resp. '--stats-children' for more details)
webpack compiled with 71 warnings
ℹ 「wdm」: Compiled with warnings.


If I remember correctly I then could already see stuff running on the https://localhost:8009 (ignoring the warnings about the self-signed certificate). Anyways I continued following the week01 instructions and opened the plutus-apps once more, executed the nix-shell again and then navigated to the repo of the plutus-pioneer-program, which I had cloned earlier. There I changed directory to code/week01 and

$ cabal update
$ cabal build

the project. However the auction game is not visible anywhere. The plutus playground is visible on https://localhost:8009, but I do not see the auction game. Help anyone?

1 Answer 1

3

You have to copy the file plutus-pioneer-program/code/week01/src/Week01/EnglishAuction.hs manually and paste it in the playground running in the Browser(you can delete the text in an example contract that is in the playground already and paste it in its place) and compile.

For example one handy cli method in 2 steps is
step-1: xclip -i plutus-pioneer-program/code/week01/src/Week01/EnglishAuction.hs
step-2: simultaneous right and left mouseclick to paste and erase from clipboard.(Paste in the playground running in the browser)

cabal build command is useful so that you can run cabal repl from the terminal for an interactive session with the auction contract.

5
  • 2
    Typo in xclip
    – Travis
    Jan 17 at 20:15
  • add two empty spaces after a line for new-line so that steps 1 and 2 start at new lines.
    – Hud
    Jan 18 at 14:33
  • Thanks. Where should I copy the EnglishAuction.hs into? Into the plutus-apps/plutus-playground-client directory? Why can I not just use cp ? Where do I run the cabal build? and when? before or after I run the server?
    – Marlo
    Jan 18 at 17:38
  • Should one typically run the cabal build inside the nix-shell, I guess so right?
    – Marlo
    Jan 18 at 17:40
  • I copied the EnglishAuction.hs into the plutus-playground-client directory (actually with cp, the double clicking thing didnt work for me the first time) and cabal build everthing inside a nix-shell again in that directory (dont know whether that was necessary). Then I started the server and npm run start in another nix shell. The playground opens up again, but I do not see the EnglishAuction. I see (as before): "Demo files", "Hello, world", "Starter", "Game", "Vesting", "Crowd Funding" and "Error Handling". But no English Auction. Maybe I'm looking in the wrong place?
    – Marlo
    Jan 18 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.