0

I'm following this guide for setting up my Plutus Environment which uses Vagrant & VirtualBox.

At the step:

In the Vagrantfile directory run & wait for provisioning to finish: vagrant up

I run into multiple Vim errors-

plutus-node-1: Vim: Warning: Output is not to a terminal
plutus-node-1: Vim: Warning: Input is not from a terminal
plutus-node-1: Error detected while processing /home/vagrant/.vimrc:
plutus-node-1: line    1:
plutus-node-1: E488: Trailing characters
plutus-node-1: line    2:
plutus-node-1: E492: Not an editor command: ^M
plutus-node-1: line    3:
plutus-node-1: E116: Invalid arguments for function plug#
plutus-node-1: line    4:
plutus-node-1: E492: Not an editor command: ^M
plutus-node-1: line    5:
plutus-node-1: E488: Trailing characters
plutus-node-1: line    6:
plutus-node-1: E492: Not an editor command: ^M
plutus-node-1: line    7:
plutus-node-1: E492: Not an editor command: ^M
plutus-node-1: line   10:
plutus-node-1: E474: Invalid argument: encoding=utf-8^M
plutus-node-1: line   11:
plutus-node-1: E492: Not an editor command: ^M
plutus-node-1: line   13:
plutus-node-1: E488: Trailing characters: hidden^M
plutus-node-1: line   14:
plutus-node-1: E492: Not an editor command: ^M

Vim: Error reading input, exiting...d/j: screen/page/line down, b/u/k: up, q: quit
plutus-node-1: Vim: Finished.
plutus-node-1: Press ENTER or type command to continueVim: Error reading input, exiting...
plutus-node-1: Vim: Finished.

Any ideas?

1
  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Jan 16, 2022 at 3:51

1 Answer 1

1

There are a few things. First of why is there a /home/vagrant/.vimrc in the first place? Second why does it contain ^M (that's effectively \r), in there? dos2unix on /home/vagrant/.vimrc should fix that.

Are you using WSL by any chance? I'm unsure how windows line endings could end up in your .vimrc otherwise.

1
  • I'm not using WSL, just using Windows 10 command prompt. To your first two questions I don't really have an answer, I haven't done anything beyond installing Vagrant & Oracle VM and then the followed the steps indicated in that post. I tried what you suggested but still doesn't work, I'm getting a new error now I believe ? Error detected while processing function <SNR>8_install[1]..<SNR>8_update_impl[ plutus-node-1: 114]..<SNR>8_update_vim[4]..<SNR>8_tick: plutus-node-1: line 17: plutus-node-1: E117: Unknown function: coc#status Jan 16, 2022 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.