0

MacOs Catalina 10.15.7 (Intel)

After facing issue here, I ran the command GC_DONT_GC=1 npm run start and it build some libraries, however failed with following error (plutus-playground-server was up and running):

79 silly inflate node_modules/@xtuc/ieee754
80 http fetch GET 200 https://registry.npmjs.org/@webassemblyjs%2fleb128 119ms (cache revalidated)
81 silly inflate node_modules/@xtuc/long
2686 error                         ^
2686 error ../src/libsass/src/ast.hpp:1616:14: note: use reference type 'const std::__1::basic_string<char> &' to prevent copying
2686 error         for (const auto denominator : denominators)
2686 error              ^~~~~~~~~~~~~~~~~~~~~~~~
2686 error                         &
2686 error 2 warnings generated.
2686 error In file included from ../src/binding.cpp:1:
2686 error In file included from ../../nan/nan.h:56:
2686 error In file included from /Users/CrosbyTop/Library/Caches/node-gyp/17.0.1/include/node/node.h:63:
2686 error In file included from /Users/CrosbyTop/Library/Caches/node-gyp/17.0.1/include/node/v8.h:25:
2686 error In file included from /Users/CrosbyTop/Library/Caches/node-gyp/17.0.1/include/node/v8-array-buffer.h:12:
2686 error In file included from /Users/CrosbyTop/Library/Caches/node-gyp/17.0.1/include/node/v8-local-handle.h:12:
2686 error /Users/CrosbyTop/Library/Caches/node-gyp/17.0.1/include/node/v8-internal.h:566:38: error: no template named 'remove_cv_t' in namespace 'std'; did you mean 'remove_cv'?
2686 error             !std::is_same<Data, std::remove_cv_t<T>>::value>::Perform(data);
2686 error                                 ~~~~~^~~~~~~~~~~
2686 error                                      remove_cv
2686 error /Library/Developer/CommandLineTools/usr/bin/../include/c++/v1/type_traits:697:50: note: 'remove_cv' declared here
2686 error template <class _Tp> struct _LIBCPP_TEMPLATE_VIS remove_cv
2686 error                                                  ^
2686 error 1 error generated.
2686 error make: *** [Release/obj.target/binding/src/binding.o] Error 1
2686 error gyp ERR! build error
2686 error gyp ERR! stack Error: `make` failed with exit code: 2
2686 error gyp ERR! stack     at ChildProcess.onExit (/Users/CrosbyTop/projects/cardano/ppp3/plutus-apps/plutus-playground-client/node_modules/node-gyp/lib/build.js:194:23)
2686 error gyp ERR! stack     at ChildProcess.emit (node:events:390:28)
2686 error gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)
2686 error gyp ERR! System Darwin 19.6.0
2686 error gyp ERR! command "/usr/local/Cellar/node/17.0.1/bin/node" "/Users/CrosbyTop/projects/cardano/ppp3/plutus-apps/plutus-playground-client/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--verbose" "--libsass_ext=" "--libsass_cflags=" "--libsass_ldflags=" "--libsass_library="
2686 error gyp ERR! cwd /Users/CrosbyTop/projects/cardano/ppp3/plutus-apps/plutus-playground-client/node_modules/node-sass
2686 error gyp ERR! node -v v17.0.1
2686 error gyp ERR! node-gyp -v v7.1.2
2686 error gyp ERR! not ok
2686 error Build failed with error code: 1
2687 verbose exit 1
1
  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Jan 16, 2022 at 3:42

2 Answers 2

0

Actually, changing node-sass version to ^7.0.0 inside package-json helped me, however I am not sure it did not break any dependencies. Node 17+ is not supported by node-sass ^5.

1
  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Jan 16, 2022 at 4:21
0

It also helped me to run the server with that prefix as well:

cd plutus-playground-server
GC_DONT_GC=1 plutus-playground-server

I used setup instructions from here and it worked for me: https://github.com/renzwo/cardano-plutus-apps-install-m1/blob/main/README.md

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.