1

I've been a mainframe programmer my for decades. Never developed on small server platforms. So the biggest challenge I'm having is dealing with the nerve wracking OS setup, Github cloning, server building, nix running craziness, etc etc etc

These are the steps I accomplished leading up to my Failed Compile.

I followed The Plutus Playground Local Instance Instructions in the Plutus Env: Setup Starter Pack

1 Installed WSL (Ubuntu) (couldn't get git to work until I did this.) Tried multiple thing. But only this worked.

then:

  1. Download the plutus-apps repository: git clone https://github.com/input-output-hk/plutus-apps COMPLETED

  2. Go to the latest commit of the repository: git checkout 41149926c108c71831cfe8d244c83b0ee4bf5c8a COMPLETED

  3. At top of this repo, nix-build -A plutus-playground.server
    COMPLETED

This ran ALL night, went to bed and arrived to this in the morning

4 Enter nix-shell then: This ran literally all day and finished at the $prompt enter image description here COMPLETED

after nix-shell build stopped entered these two cmnds:

[nix-shell:~/plutus-apps]$ cd plutus-playground-client
[nix-shell:~/plutus-apps/plutus-playground-client]$ npm run start

That ran a little while and ended with COMPLETED

I then navigated to localhost in browser which loaded the demo code to be compiled. I hit the compile button , it displayed a Compilation Failed message and display the following errors in the Linux Command window: enter image description here FAILED

New contributor
CryptoBoomer is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
4
  • "This ran literally all day and finished at the $prompt", did you add the IOG caches to your nix configuration? That could explain why it built so much.
    – angerman
    Jan 14 at 4:33
  • No, I saw mention of that after the fact in the week #1 Exercises. Jan 14 at 6:22
  • No, I saw mention of that after the fact in the week #1 Exercises. I figured at some point I should go back and do that. It def should've been in the Plutus Env: Setup Starter Pack instructions, it would've saved me a lot of time. I have no choice but to push through all the apps I don't know (Linux, Nix, Haskell etc and learn on the fly through trial and error. Thanks man. Jan 14 at 6:29
  • FYI, I answered another question that's similar but not the same here that shows some details of a new tool I created that's a little less convoluted. It uses the power of nix to abstract away a lot of the ugliness. cardano.stackexchange.com/a/6464/382 Jan 15 at 3:29
0

Notwithstanding the value/importance of cache issue pointed out by @angerman, the cause of the main question of your OP (i.e., the error on port 8080) appears to be that you started the client on 8009, but didn't show any steps for starting the server.

Open a second terminal session, enter the nix-shell, and start the server, and you should be set.

New contributor
Hysteria is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • Thanks, this is great. I see that I missed that step on the Setup Starter Pack. Can I ask another quick question? Cache setup says to update /etc/nix/nix.conf Where is the /etc folder? I haven't been able to locate it. Do I have to create it? If so what folder do I create it in. Jan 14 at 18:29
0

You should find the necessary etc/ folder from your root directory. In a terminal, you can do the following from anywhere to get there.

:~/plutus-apps$ cd /

bring you to this prompt...

:/$

that is your root dir/path (/) prompt

now;

:/$ ls

...and you should see something like this...

bin dev home lib32 libx32 media nix proc run snap sys usr

boot etc lib lib64 lost+found mnt opt root sbin srv tmp var

Note the etc/ dir. Now that you know where it is, from here just change to the etc/ directory. If you need to make a nix folder, simply use the mkdir command.

I am not sure how comfortable you are in the bash shell. If you are, here is a handy concatenated line to mkdir and create a nix.conf file at the same time:

sudo mkdir folder && sudo touch $_/file.txt

or -> sudo mkdir etc/nix/ && sudo touch $_/nix.conf

I hope that helps you out with this. Good luck!

New contributor
Troy Bertolino is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • 1
    This my friend is excellent!! Thank you so much Jan 14 at 23:36

Your Answer

CryptoBoomer is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.