$ nix --version
nix (Nix) 2.5.1

$ ghci --version
The Glorious Glasgow Haskell Compilation System, version

$ cat /etc/issue
Ubuntu 21.10 \n \l

I have the plutus playground server running inside a nix-shell in another terminal:

$ netstat -natlp | grep plutus
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp        0      0  *               LISTEN      3772215/plutus-play

Then i get into another nix-shell, cd to the plutus-playground-client (i already did git checkout 41149926c108c71831cfe8d244c83b0ee4bf5c8a) and run npm start or npm run start

This is what i'm getting anyway:

16:33 :) ../plutus-playground-client # npm start

> [email protected] start /home/atcasanova/plutus/plutus-apps/plutus-playground-client
> plutus-playground-generate-purs && npm install && npm run install:spago && npm run build:webpack:dev

[Info] Running: (Nothing,PSGenerator {_outputDir = "generated"})
The following purescript packages are needed by the generated code:

  - plutus-playground-client
  - purescript-argonaut-codecs
  - purescript-either
  - purescript-enums
  - purescript-lists
  - purescript-maybe
  - purescript-newtype
  - purescript-ordered-collections
  - purescript-prelude
  - purescript-profunctor-lenses
  - purescript-tuples
  - web-common

Successfully created your PureScript modules!

Successfully created your servant API purescript functions!
Please make sure you have purescript-servant-support and purescript-bridge-json-helpers installed

plutus-playground-server: user error (Error evaluating simulation: InterpreterError (CompilationErrors [RawError "/nix/store/xvj7mn015p98yypgwvzk4cq31b9j5xq7-plutus-ledger-constraints-lib-plutus-ledger-constraints- undefined symbol: plutuszmledgerzmapizm0zi1zi0zi0zmKIxxnVyHrLq1ei02VYnb9P_PlutusziV1ziLedgerziBytes_zdwzdcshowsPrec_info\n"]))
npm ERR! errno 1
npm ERR! [email protected] start: `plutus-playground-generate-purs && npm install && npm run install:spago && npm run build:webpack:dev`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2022-01-13T19_34_10_171Z-debug.log

4 Answers 4


I was able to overcome this issue by running GC_DONT_GC=1 npm start.

  • What exactly that means? Jan 15, 2022 at 15:50
  • Can you make this answer more clear and explicit? We are catering to varied skill levels and many visitors whose native language is not English. The few extra minutes it takes to make the answer clear and precise benefits everybody.
    – gRebel
    Jan 16, 2022 at 3:20
  • It will also make it more likely that @alfredo will mark it as the accepted answer. ;-)
    – gRebel
    Jan 16, 2022 at 3:23

I guess it's fixed.

At first i was running the ubuntu-packed version of nix-bin, which was 2.3.10. I then downloaded the newest version of nix following these instructions.

After loading the new version (since i've installed it with the --no-daemon flag i had to load a shell script) it kept malfunctioning. Then another user on the discord channel told me it would be nice to do a garbage collect and rebuild the server since i changed versions.

nix-build -A plutus-playground.server

It took a few hours but when it was done i've got everything running.


Please make sure you have purescript-servant-support and purescript-bridge-json-helpers installed

Have you tried installing those ?

  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Jan 14, 2022 at 4:49

I had the same issue with the commit from the setup guide 41149926c108c71831cfe8d244c83b0ee4bf5c8a. Using different commit worked for me. You can try git checkout 7f53f18dfc788bf6aa929f47d840efa1247e11fd.

  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Jan 14, 2022 at 5:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.