0

I am facing this issues when running

$ nix-build -A plutus-playground.server
> error: 1 dependencies of derivation
> '/nix/store/39qxl421bhkzks2zrra7vy3yl6qqhsib-zlib-lib-zlib-0.6.2.3-config.drv'
> failed to build

It is probably RAM size issue. What is minimum RAM for running plutus-playground-server on Ubuntu VirtualBox?

4
  • I would be surprised if it worked in less that 8G of RAM. Having a decent amount of swap would not hurt either. Commented Jan 13, 2022 at 8:26
  • I increased to 10GB fo Virtual Box and $nix-build -A plutus-playground.server run successfully. Swap set to 2GB in VM
    – Miro
    Commented Jan 13, 2022 at 8:38
  • Welcome to Cardano SE! As a new user be sure to take the Tour.
    – gRebel
    Commented Jan 18, 2022 at 23:28
  • This question could be improved and is not generating good quality answers, please read How to Answer and the relevant pinned messages in help center if you are going to answer this question.
    – gRebel
    Commented Jan 18, 2022 at 23:38

2 Answers 2

1

As all answers, it depends on your setup. Currently I run the plutus-playground-server setup on a VM with 8gb of ram available (but the playground only uses 1gb of that space). The thing to consider and optimize is the way you run you VM. I run my VM with the libvirt stack (this hypervisor runs near native hardware speeds, very lightweigth). Also I do not render a DE on my VM. I just SSH into the VM and only use the terminal, this also saves a lot of ram usage. So I guess that 2gb will suffice bare minimum (I have not tested this).

a good guide for this hypervisor: https://octetz.com/docs/2020/2020-05-06-linux-hypervisor-setup/

Good luck!

0

I have seen, that my setup needs around 12GB. Maybe you can optimize it more, but for me it was around 12GB.

Not the answer you're looking for? Browse other questions tagged or ask your own question.