0

I have successfully installed nix, cabal and have setup the IOHK binary cache. I cloned the plutus-app repository and successfully built the Haskell packages and other artifacts with nix. Then running nix-shell successfully I get into the nix-shell prompt:

[nix-shell:/home/datapool/plutus-apps]$

I then issue the following commands:

[nix-shell:/home/datapool/plutus-apps]$ cd plutus-playground-client
[nix-shell:/home/datapool/plutus-apps/plutus-playground-client]$ npm run start

I then get this output:

> plutus-playground-client@1.0.0 start /home/datapool/plutus-apps/plutus-playground-client
> plutus-playground-generate-purs && npm install && npm run install:spago && npm run build:webpack:dev

 /nix/store/ry2hywgh6cmmm9d5b9566nxdskd752yc-plutus-playground-generate-purs/bin/plutus-playground-generate-purs: line 6: /bin/plutus-playground-server: No such file or directory
 npm ERR! code ELIFECYCLE
 npm ERR! syscall spawn
 npm ERR! file sh
 npm ERR! errno ENOENT
 npm ERR! plutus-playground-client@1.0.0 start: `plutus-playground-generate-purs && 
 npm install && npm run install:spago && npm run build:webpack:dev`
 npm ERR! spawn ENOENT
 npm ERR! 
 npm ERR! Failed at the plutus-playground-client@1.0.0 start script.
 npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

 npm ERR! A complete log of this run can be found in:
 npm ERR!     /home/brightchip/.npm/_logs/2022-01-12T13_05_31_245Z-debug.log

As the output says, it seems to be looking for a non-existent /bin/plutus-playground-server.

Same problem when I run the server:

[nix-shell:/home/datapool/plutus-apps/plutus-playground-client]$ plutus-playground-server
plutus-playground-server: for development use only
/nix/store/fm77y43lzpgnay4pyc48jwpln0lnmrk3-plutus-playground-server/bin/plutus-playground-server: line 10: /bin/plutus-playground-server: No such file or directory

Any idea what I might be missing or how to debug?

3 Answers 3

1

Looks related to an issue I ran into where the directories were missing. I needed to git checkout a patch.

Possible solution - https://cardano.stackexchange.com/a/6251/6004

The instructions are at :

https://tutorials.cardanoacademy.io/plutus-pioneer-program/setting-up-plutus-playground/cloning-plutus-repository

1

Thanks. The patch works:

git checkout 3746610e53654a1167aeb4c6294c6096d16b0502
0

I don't know exactly why, but doing this fixed it for me:

# In the plutus-apps folder
GC_DONT_GC=1 nix-build ./default.nix -A plutus-apps.haskell.packages.plutus-playground-server.components.exes.plutus-playground-server
# That will build a bash script somewhere (in store)
# edit that file located in this path:
whereis plutus-playground-server
# replace subshell (in Line 10) with the path from last nix-build command
# edit the file from this path: /nix/store/*-plutus-playground-generate-purs/bin/plutus-playground-generate-purs
# replace subshell (in Line 6) with the path from last nix-build command
cd plutus-playground-client
nix-shell
plutus-playground-server

Source: https://github.com/NixOS/nix/issues/4246#issuecomment-738888246

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.