2

In the VS Code Docker Env setup on a Mac. I opened the starter project in the container. Ran cabal build in VS Terminal with devcontainer prompt.

Warning: Requested index-state 2021-08-14T00:00:00Z is newer than
'hackage.haskell.org'! Falling back to older state ().
Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: plutus-core-0.1.0.0 (user goal)
[__1] unknown package: plutus-core:happy:exe.happy (dependency of plutus-core)
[__1] fail (backjumping, conflict set: plutus-core, plutus-core:happy:exe.happy)

After searching the rest of the dependency tree exhaustively, these were the goals I've had most trouble fulfilling: plutus-core, plutus-core:happy:exe.happy

I get the same error with all the starter-pap commands

1 Answer 1

2

The line Falling back to older state () means you probably need to run cabal update first (which downloads a copy of the current hackage index state).

2
  • After running cabal update, cabal build was killed because a process used too much memory. I increased Docker memory to 3GB Failed to build iohk-monitoring-0.2.0.0 (which is required by exe:plutus-starter-pab from plutus-starter-0.1.0.0 and test:plutus-example-projects-test from plutus-starter-0.1.0.0). The build process was killed (i.e. SIGKILL). The typical reason for this is that there is not enough memory available (e.g. the OS killed a process using lots of memory). Jan 12, 2022 at 6:49
  • You will need at least 8G of RAM (including swap). Jan 12, 2022 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.