7

I am in the 3rd pioneers cohort, going through the env setup. I have Mac M1 with Monterey. I installed nix and added config for the caches etc as recommended here: https://github.com/input-output-hk/plutus-apps#nix-on-macos

When I run "nix-build -A plutus-playground.server", it ends with:

unpacking source archive /private/tmp/nix-build-source.drv-0/f089a6f090cdb35fcf95f865fc6a31ba6b3ac4eb.tar.gz error: attribute 'aarch64-darwin' missing

   at /nix/store/cyfj6bd0n0ckvkm67mhjyg1qcvrfgsg9-source/artifact.nix:11:10:

       10| let
       11|   host = hosts.${stdenv.targetPlatform.system};
         |          ^
       12| (use '--show-trace' to show detailed location information)

has anyone managed to build and run the Plutus playground on M1 Mac ?

3 Answers 3

3

We do not currently have native support for aarch64-darwin (macOS on Apple Silicon chips). I expect this will come throughout the year. For now please use rosetta2. We also do not have caches for aarch64-darwin yet.

Try to pass the system string to nix like so:

$ nix-build -A plutus-playground.server --argstr system x86_64-darwin
2
  • Hi @angerman, thanks for the answer. I am getting segmentation fault when I run it with the additional parameter: unpacking source archive /private/tmp/nix-build-source.drv-0/c8c5e6a6fbb12a73598d1a434984a36e880ce3cf.tar.gz zsh: segmentation fault nix-build -A plutus-playground.server --argstr system x86_64-darwin
    – Bronya
    Jan 12, 2022 at 15:20
  • Did you by any chance have sandbox = true in your nix config?
    – angerman
    Jan 17, 2022 at 4:34
3

This guide worked to get me past the server build: https://github.com/renzwo/cardano-plutus-apps-install-m1/blob/main/README.md

2

Apple M1 seems to be supported meanwhile. This finally worked for me:

$ git clone https://github.com/input-output-hk/plutus-apps
$ cabal update
$ nix-build -A plutus-playground.server
$ nix-build -A plutus-playground.client
$ nix-shell
1
  • Any additional nix configs especially for mac/m1 needed before you ran these commands @Dirk?
    – jerome
    May 7, 2022 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.