1

I'm following the instructions for installing the Plutus-playground found here

I discovered I must execute the following before step 10

git clone https://github.com/input-output-hk/plutus-apps.git

I cd into plutus-apps/ and this then worked fine (note: in zsh):

[zsh]$ pwd
/Users/jwb/plutus/plutus-apps
[zsh]$ nix-build -A plutus-playground.client

But I got a "segmentation fault" with this:

[zsh]$ nix-build -A plutus-playground.server

Here is the output for clarity:

[zsh]$ nix-build -A plutus-playground.server
zsh: segmentation fault  

I switched to bash after the error, but that too failed:

[bash]$ nix-build -A plutus-playground.server
Segmentation fault: 11

Is the plutus-apps repository corrupted? Why would the client build just fine but not the server?

1 Answer 1

2

Could you try running GC_DONT_GC=1 nix-build -A plutus-playground.server.

1
  • Running macOS Big Sur and this answer solved it for me
    – caike
    Jan 14, 2022 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.