0

I'm trying to install nix on my macbook but I had following error message. How can I fix this certificate expired problem?

macOS : High Sierra 10.13.6

Thanks in advance.

//-- error message ---

~ MyMac$ sh <(curl -L https://nixos.org/nix/install) --darwin-use-unencrypted-nix-store-volume % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (60) SSL certificate problem: certificate has expired More details here: https://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle" of Certificate Authority (CA) public keys (CA certs). If the default bundle file isn't adequate, you can specify an alternate file using the --cacert option. If this HTTPS server uses a certificate signed by a CA represented in the bundle, the certificate verification probably failed due to a problem with the certificate (it might be expired, or the name might not match the domain name in the URL). If you'd like to turn off curl's verification of the certificate, use the -k (or --insecure) option. HTTPS-proxy has similar options --proxy-cacert and --proxy-insecure.

1 Answer 1

1

This is not really Cardano question, but seems your Mac has problem with certificates.

Quick fix will be just to add -k, like this:

sh <(curl -k -L https://nixos.org/nix/install) --darwin-use-unencrypted-nix-store-volume

This will ignore certificate issue.

In longrun you need to dig dipper, maybe you need to reinstall your root certificates, or update your MacOS.

Maybe this will help:

https://www.digicert.com/blog/expired-intermediate-certificate

7
  • Thank you for your kind answer. in fact I've tried to add -k option but it is not working as below. MyMac$ sh <(curl -k nixos.org/nix/install) --darwin-use-unencrypted-nix-store-volume % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0, I'll dig into more as your help.
    – Tae Euy
    Jan 11, 2022 at 11:30
  • You forgot -L in your command. Just copy from here sh <(curl -k -L https://nixos.org/nix/install) --darwin-use-unencrypted-nix-store-volume
    – os11k
    Jan 11, 2022 at 11:35
  • Yes, you're right. it seems working. thank you so much!
    – Tae Euy
    Jan 11, 2022 at 11:38
  • If it worked, I would appreciate if you will accept my answer as solution. Cheers!
    – os11k
    Jan 11, 2022 at 11:41
  • 1
    I've also up-voted the answer but would caution against having non-Cardano questions here going forward. Jan 11, 2022 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.