I am encountering a problem when trying to run the Plutus Playground through Nix on MacOS.

I tried using the last available tag v2021-12-20, but I am getting the following error when I try to run the Plutus Playground Client in nix-shell:

nix-shell:~/cardano/plutus-apps/plutus-playground-client]$ npm run start

> [email protected] start /Users/matt/cardano/plutus-apps/plutus-playground-client
> plutus-playground-generate-purs && npm install && npm run install:spago && npm run build:webpack:dev

/nix/store/2nr8xfy3zqdgxfmxlc3r48gijfdwbnrf-plutus-playground-generate-purs/bin/plutus-playground-generate-purs: line 6: /bin/plutus-playground-server: No such file or directory
npm ERR! syscall spawn
npm ERR! file sh
npm ERR! errno ENOENT
npm ERR! [email protected] start: `plutus-playground-generate-purs && npm install && npm run install:spago && npm run build:webpack:dev`
npm ERR! spawn ENOENT
npm ERR!
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/matt/.npm/_logs/2021-12-20T18_27_49_943Z-debug.log

It seems similar to Plutus Playground Client cannot run, but I couldn't find anything to help run it.

My Nix config:

uild-users-group = nixbld

substituters        = https://hydra.iohk.io https://iohk.cachix.org https://cache.nixos.org/
trusted-public-keys = hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ= iohk.cachix.org-1:DpRUyj7h7V830dp/i6Nti+NEO2/nhblbov/8MW7Rqoo= cache.nixos.org-1:6NCHdD59X431o0gWypbMrAURkbJ16ZPMQFGspcDShjY=

sandbox = false

system = x86_64-darwin
extra-platforms = x86_64-darwin aarch64-darwin

I am running it on an M1 Mac.

  • Did you read cardano.stackexchange.com/q/4035/1130 Dec 21, 2021 at 9:32
  • 1
    If that addressees your issue, let’s try to dedupe these questions for the next person. Dec 21, 2021 at 9:35
  • I read this guide, but that's mainly regarding the build of the cardano node. I tried building the node using the nix and everything was fine in this case. When using the nix-shell, I don't have any problem running the plutus-playground-server, but the plutus-playground-client fails. Dec 21, 2021 at 10:43


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.